Bug 1343584 - dismissed events comments
Summary: dismissed events comments
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 2
Assignee: Karnan
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-06-07 13:53 UTC by Lubos Trilety
Modified: 2016-08-23 19:55 UTC (History)
5 users (show)

Fixed In Version: rhscon-core-0.0.34-1.el7scon.x86_64 rhscon-ceph-0.0.33-1.el7scon.x86_64 rhscon-ui-0.0.47-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:55:09 UTC
Target Upstream Version:


Attachments (Terms of Use)
dismissed event (54.55 KB, image/png)
2016-06-07 13:53 UTC, Lubos Trilety
no flags Details
double dismissed event (61.24 KB, image/png)
2016-06-07 13:55 UTC, Lubos Trilety
no flags Details
event details design (262.89 KB, image/png)
2016-06-16 08:25 UTC, Lubos Trilety
no flags Details
Events screen (364.79 KB, image/png)
2016-06-16 08:29 UTC, Nishanth Thomas
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Lubos Trilety 2016-06-07 13:53:56 UTC
Created attachment 1165658 [details]
dismissed event

Description of problem:
Comment given during an event dismiss is displayed as an action. Via design there should be another section with comments.
Moreover already manually dismissed event could still be dismissed by system.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.21-1.el7scon.x86_64
rhscon-ceph-0.0.20-1.el7scon.x86_64
rhscon-ui-0.0.34-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create some event, e.g. stop some cluster host machine
2. Dismiss the created event, put some comment there
3. List the event and open its details

Actual results:
A comment is displayed as an action in 'history' section

Expected results:
The action in history should be 'Dismissed' and all comments should have special section.

Additional info:

Comment 1 Lubos Trilety 2016-06-07 13:55:16 UTC
Created attachment 1165660 [details]
double dismissed event

event dismissed both by user and by system

Comment 2 Nishanth Thomas 2016-06-16 06:42:08 UTC
Events page is inline with the design. The comments option present in the details page of an alert which is not dismissed. Once dismissed, the text wi8ll move into the 'Action' table. screen shot attached

User dimissed events can be dismissed by system. This happens when a clear event generated for the alert(example cluster status transitioning from err to OK)
So this also a expected behavior.

closing this bug as it works as expected

Comment 3 Lubos Trilety 2016-06-16 08:25:40 UTC
Created attachment 1168629 [details]
event details design

Comment 4 Nishanth Thomas 2016-06-16 08:29:19 UTC
Created attachment 1168631 [details]
Events screen

Comment 5 Lubos Trilety 2016-06-16 09:11:49 UTC
(In reply to Nishanth Thomas from comment #2)
> Events page is inline with the design. The comments option present in the
> details page of an alert which is not dismissed. Once dismissed, the text
> wi8ll move into the 'Action' table. screen shot attached
> 

It doesn't make sense if only user comment is displayed as an action as user could fill there anything viz attachment 1165660 [details]
There could be something like 'Dismissed: <comment>' though. That will also cover the case when user doesn't fill anything to comment. As for now the related action is empty in 'History' table if that happens.

> User dimissed events can be dismissed by system. This happens when a clear
> event generated for the alert(example cluster status transitioning from err
> to OK)
> So this also a expected behavior.
> 
> closing this bug as it works as expected

I think that's not OK. Dismissed event should not be possible to dismiss again. On the other hand I agree that it's just superficial issue as it doesn't cause anything.

Opening it again for the first issue.

Comment 6 Ju Lim 2016-06-17 16:38:06 UTC
Actual
------
From looking at the current implementation, here's what I observed:

1. When user puts in Comment, user has to click on "Dismiss" and the Comment moves up to the list under "History."
2. Current implementation seems to combine the Dismiss and Add (Comments) actions together

Expected / Design
-----------------
1. The actions of Dismiss should actually be under the "Actions" listbox at the top per the design (and not at the bottom with Comments.
2. When user adds a Comment, they should click on "Add" to do so (vs. Dismissed).
3. Once an event is dismissed, user should not be able to dismiss the said event again unless we provide the ability for users to "Undismiss" an event.

Comment 7 Nishanth Thomas 2016-06-22 08:52:51 UTC
Add comments(alone) functionality is out of 2.0 as agreed on the bu scrub meeting. What we implement here is that appending "Dismissed" along with the text which fed in as part of "dismiss" action

Comment 8 Karnan 2016-07-07 07:09:53 UTC
Appended "Dismissed:" before user comment

Comment 10 Lubos Trilety 2016-07-21 11:57:17 UTC
Tested on:
rhscon-ceph-0.0.33-1.el7scon.x86_64
rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-core-0.0.34-1.el7scon.x86_64
rhscon-ui-0.0.48-1.el7scon.noarch

Action look like 'Dismissed: <message>'.

Comment 12 errata-xmlrpc 2016-08-23 19:55:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.