Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1343618 - Can't stop the SPM due to uncleared task in HE config retrieval flow
Summary: Can't stop the SPM due to uncleared task in HE config retrieval flow
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 4.0.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ovirt-4.0.0-rc
: 4.0.0
Assignee: Liron Aravot
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-07 14:30 UTC by Nikolai Sednev
Modified: 2017-05-11 11:19 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-05 07:46:09 UTC
oVirt Team: Storage
rule-engine: ovirt-4.0.0+
ylavi: blocker-
rule-engine: planning_ack+
rule-engine: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
sosreport from host alma03 (12.22 MB, application/x-xz)
2016-06-07 14:32 UTC, Nikolai Sednev
no flags Details
sosreport from host alma04 (6.63 MB, application/x-xz)
2016-06-07 14:34 UTC, Nikolai Sednev
no flags Details
sosreport from engine (8.26 MB, application/x-xz)
2016-06-07 14:35 UTC, Nikolai Sednev
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 58807 0 master MERGED core: HE - uploadImageToStream task is never cleared 2016-06-14 08:09:59 UTC
oVirt gerrit 59101 0 ovirt-engine-4.0 MERGED core: HE - uploadImageToStream task is never cleared 2016-06-14 08:14:14 UTC

Description Nikolai Sednev 2016-06-07 14:30:23 UTC
Description of problem:
Failed to force select (my host's FQDN) as the SPM due to a failure to stop the current SPM.

I've tried to manually set SPM to run on alma04 via WEBUI and failed.

Version-Release number of selected component (if applicable):
Engine:
rhevm-4.0.0.2-0.1.el7ev.noarch
rhevm-guest-agent-common-1.0.12-1.el7ev.noarch
rhevm-branding-rhev-4.0.0-0.0.master.20160531161414.el7ev.noarch
rhevm-dependencies-4.0.0-1.el7ev.noarch
rhevm-setup-plugins-4.0.0-1.el7ev.noarch
rhevm-doc-4.0.0-2.el7ev.noarch
ovirt-engine-setup-plugin-ovirt-engine-4.0.0.2-0.1.el7ev.noarch
ovirt-vmconsole-1.0.3-1.el7ev.noarch
ovirt-engine-extension-aaa-jdbc-1.1.0-1.el7ev.noarch
ovirt-engine-setup-base-4.0.0.2-0.1.el7ev.noarch
ovirt-engine-websocket-proxy-4.0.0.2-0.1.el7ev.noarch
ovirt-image-uploader-4.0.0-1.el7ev.noarch
ovirt-engine-backend-4.0.0.2-0.1.el7ev.noarch
ovirt-engine-tools-4.0.0.2-0.1.el7ev.noarch
ovirt-engine-lib-4.0.0.2-0.1.el7ev.noarch
ovirt-engine-dwh-setup-4.0.0-2.el7ev.noarch
ovirt-log-collector-4.0.0-1.el7ev.noarch
ovirt-engine-vmconsole-proxy-helper-4.0.0.2-0.1.el7ev.noarch
ovirt-host-deploy-java-1.5.0-1.el7ev.noarch
ovirt-engine-dbscripts-4.0.0.2-0.1.el7ev.noarch
ovirt-engine-4.0.0.2-0.1.el7ev.noarch
ovirt-engine-setup-plugin-websocket-proxy-4.0.0.2-0.1.el7ev.noarch
ovirt-engine-tools-backup-4.0.0.2-0.1.el7ev.noarch
ovirt-engine-userportal-4.0.0.2-0.1.el7ev.noarch
ovirt-engine-setup-4.0.0.2-0.1.el7ev.noarch
ovirt-vmconsole-proxy-1.0.3-1.el7ev.noarch
ovirt-engine-restapi-4.0.0.2-0.1.el7ev.noarch
ovirt-engine-cli-3.6.2.0-1.el7ev.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-4.0.0.2-0.1.el7ev.noarch
ovirt-engine-extensions-api-impl-4.0.0.2-0.1.el7ev.noarch
ovirt-iso-uploader-4.0.0-1.el7ev.noarch
ovirt-engine-webadmin-portal-4.0.0.2-0.1.el7ev.noarch
ovirt-engine-dwh-4.0.0-2.el7ev.noarch
ovirt-engine-setup-plugin-vmconsole-proxy-helper-4.0.0.2-0.1.el7ev.noarch
ovirt-host-deploy-1.5.0-1.el7ev.noarch
ovirt-setup-lib-1.0.2-1.el7ev.noarch
ovirt-engine-sdk-python-3.6.5.0-1.el7ev.noarch
Linux version 3.10.0-327.22.1.el7.x86_64 (mockbuild@x86-034.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Mon May 16 13:31:48 EDT 2016
Linux 3.10.0-327.22.1.el7.x86_64 #1 SMP Mon May 16 13:31:48 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.2 (Maipo)

Host:
ovirt-hosted-engine-ha-2.0.0-1.el7ev.noarch
mom-0.5.4-1.el7ev.noarch
ovirt-vmconsole-host-1.0.3-1.el7ev.noarch
ovirt-host-deploy-1.5.0-1.el7ev.noarch
ovirt-engine-sdk-python-3.6.5.0-1.el7ev.noarch
libvirt-client-1.2.17-13.el7_2.5.x86_64
sanlock-3.2.4-2.el7_2.x86_64
ovirt-setup-lib-1.0.2-1.el7ev.noarch
vdsm-4.18.1-11.gita92976e.el7ev.x86_64
ovirt-hosted-engine-setup-2.0.0-1.el7ev.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.15.x86_64
ovirt-vmconsole-1.0.3-1.el7ev.noarch
Linux 3.10.0-327.22.1.el7.x86_64 #1 SMP Mon May 16 13:31:48 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Linux version 3.10.0-327.22.1.el7.x86_64 (mockbuild@x86-034.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Mon May 16 13:31:48 EDT 2016
Red Hat Enterprise Linux Server release 7.2 (Maipo)

How reproducible:
100%

Steps to Reproduce:
1.Deploy 4.0 HE on two el7.2 hosts.
2.Add data storage domain and create one VM.
3.Try manually changing SPM via WEBUI.

Actual results:
Failed to force select (my host's FQDN) as the SPM due to a failure to stop the current SPM.

Expected results:
SPM should change the host accordingly to customer's choice.

Additional info:
sosreports from both hosts and the engine are attached.

Comment 1 Nikolai Sednev 2016-06-07 14:32:13 UTC
Created attachment 1165677 [details]
sosreport from host alma03

Comment 2 Nikolai Sednev 2016-06-07 14:34:25 UTC
Created attachment 1165678 [details]
sosreport from host alma04

Comment 3 Nikolai Sednev 2016-06-07 14:35:15 UTC
Created attachment 1165679 [details]
sosreport from engine

Comment 4 Red Hat Bugzilla Rules Engine 2016-06-08 07:34:04 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 5 Liron Aravot 2016-06-08 08:30:03 UTC
The bug is related to HE flow implementation, when downloading the data from the HE configuration disk the task isn't polled - when attempting to stop the spm its first checked whether there are pending tasks. as the task is never cleared on that flow it won't be possible to stop the spm.

Comment 6 Allon Mureinik 2016-06-20 12:55:54 UTC
The patch is included in ovirt-4.0.0.5

Comment 7 Raz Tamir 2016-06-23 08:22:47 UTC
Verified on rhevm-4.0.0.6-0.1.el7ev.noarch.
Selet new SPM working as expected

Comment 8 Sandro Bonazzola 2016-07-05 07:46:09 UTC
oVirt 4.0.0 has been released, closing current release.


Note You need to log in before you can comment on or make changes to this bug.