Bug 134374 - find-requires: match internal RPM behavior
Summary: find-requires: match internal RPM behavior
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-01 18:58 UTC by Bill Nottingham
Modified: 2014-03-17 02:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 21:41:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that removes filtering (536 bytes, patch)
2004-10-01 18:59 UTC, Bill Nottingham
no flags Details | Diff

Description Bill Nottingham 2004-10-01 18:58:54 UTC
RPM's internal dependency generator does not filter non-GLIBC/GCC
symbol versions, so find-requires probably shouldn't either.

Comment 1 Bill Nottingham 2004-10-01 18:59:33 UTC
Created attachment 104643 [details]
patch that removes filtering

Comment 2 Jeff Johnson 2004-10-01 21:41:03 UTC
find-requires dead and gone. if anything, I will remove
find-requires and find-provides from rpm.

Comment 3 Jeff Johnson 2004-10-01 21:45:59 UTC
Look at /usr/lib/rpm/rpmdeps for the replacement (which
uses the same internal dependency generator as rpm).

colors are not set if/when find-{requires,provides}
are used, and there is other missing
data in packages as well.

Comment 4 Bill Nottingham 2004-10-01 22:01:18 UTC
I'll bite. rpmdeps doesn't output any information related to colors at
all, so how is it missing when something else is used?

Comment 5 Jeff Johnson 2004-10-03 14:19:55 UTC
rpmdeps is a replacement for find-requires that uses the
internal dependency extraction (which filters GLIBC_PRIVATE).

rpmdeps does not generate colors, nor can colors be generated
external to rpm without breaking/changing the ancient find-requires
API.

So the only way to add coloring to package files is to use the internal
dependency generator, which has been in "production" since RHL 9.

There is --debug in rpmdeps if you need tool to identify what colors
are assigned. Other options could be added if that is your quest.
My goal writing rpmdeps was to supply a replacement for find-requires
that filtered using the internal dependency extractor, not otherwise.

Note that there is much much more than adding a color tag going
on internally. There are other properties, like ensuring that
dependencies are sorted, and that dependencies are attached per-file,
in a forward <-> backward compatible way that make any attempt
to create the information in helper using an API more than a bit
tricky.

Comment 6 Bill Nottingham 2004-10-04 03:22:49 UTC
Hm, OK. Unfortunately, I have a need to filter deps; I see this
leading to problems. :/


Comment 7 Jeff Johnson 2004-10-04 14:04:48 UTC
What problems?

You identify what you want filtered, I add internal to rpm.


Note You need to log in before you can comment on or make changes to this bug.