Bug 1343748 - unable to edit or remove custom provision dialogues
Summary: unable to edit or remove custom provision dialogues
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.5.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: GA
: 5.5.5
Assignee: lgalis
QA Contact: Jiri Stefanisin
URL:
Whiteboard: provision:dialog:ui
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-07 19:57 UTC by Colin Arnott
Modified: 2019-11-14 08:19 UTC (History)
12 users (show)

Fixed In Version: 5.5.5.2
Doc Type: Bug Fix
Doc Text:
Previously, the edit and remove toolbar options for a custom provisioning dialog were disabled after clicking on a default dialog. As a result, users were unable to edit or remove custom provisioning dialogs. This was caused by an incorrect condition in the code which has been fixed, and the edit/remove toolbar options now work as expected after clicking on a default dialog.
Clone Of:
Environment:
Last Closed: 2016-07-26 15:35:25 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
cfme-5.5.4.2: edit-remove_provision_dialogue.png (223.67 KB, image/png)
2016-06-07 19:57 UTC, Colin Arnott
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Description Colin Arnott 2016-06-07 19:57:10 UTC
Created attachment 1165759 [details]
cfme-5.5.4.2: edit-remove_provision_dialogue.png

Description of problem:
I am unable to edit or remove custom provision dialogues. Even copying the provision dialogue to a new dialogue results in no ability to edit or remove. 

Even if I create it fresh I am still not able to remove or edit.

Version-Release number of selected component (if applicable):
cfme-5.5.4.2-1.el7cf.x86_64

How reproducible:
trivial

Steps to Reproduce:
1. navigate to Automate → Customization → Provisioning Dialogs
2. copy any existing 
3.

Actual results:
edit and remove are greyed out

Expected results:
I should be able to edit or remove provisioning dialogues that I create

Additional info:
fixed in cfme-5.6.0.9-rc2.1.el7cf.x86_64

Comment 2 Colin Arnott 2016-06-07 20:00:54 UTC
Created attachment 1165760 [details]
cfme-5.6.0.9: edit-remove_provision_dialogue.png

working on cfme-5.6.0.9-rc2.1.el7cf.x86_64

Comment 5 Harpreet Kataria 2016-06-20 16:00:23 UTC
Laura,

Thi sissue only exists on 5.5.z, it was introduced in commit 0053550fe5245a67fe4074250838414463880f85. Can you please take a look, looks like if condition is incorrect on line 87 in app/helpers/application_helper/toolbar_builder.rb if bgi[:buttonSelect] == "host_vmdb_choice" && x_active_tree == :old_dialogs_tree && @record && @record[:default]
Let me know if you have questions.

Thanks,
~Harpreet

Comment 6 CFME Bot 2016-06-21 20:22:41 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=5bd76ea45b86d12a40e9721ba990d2aecc89f257

commit 5bd76ea45b86d12a40e9721ba990d2aecc89f257
Author:     Laura Galis <lgalis@redhat.com>
AuthorDate: Mon Jun 20 17:12:20 2016 -0400
Commit:     Laura Galis <lgalis@redhat.com>
CommitDate: Tue Jun 21 10:48:21 2016 -0400

    Edit/Remove toolbar options for a custom provision dialog are disbaled after clickeng on a default dialog
    
     https://bugzilla.redhat.com/show_bug.cgi?id=1343748

 app/helpers/application_helper/toolbar_builder.rb | 15 ++++++++-------
 1 file changed, 8 insertions(+), 7 deletions(-)

Comment 10 errata-xmlrpc 2016-07-26 15:35:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html


Note You need to log in before you can comment on or make changes to this bug.