Bug 134377 - Default display for top on SMP systems is broken in procps 2.0.17
Default display for top on SMP systems is broken in procps 2.0.17
Status: CLOSED DUPLICATE of bug 132091
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: procps (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-01 15:38 EDT by John Caruso
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Caruso 2004-10-01 15:38:33 EDT
Description of problem:
The default display of top is broken on SMP machines with procps 
2.0.17 (as in RHEL3 update 3).  It appears that the "I" toggle is no 
longer set correctly for top, as it was in previous procps versions.

Version-Release number of selected component (if applicable):
procps 2.0.17

How reproducible:
Run top on an SMP machine and observe the totals.

Steps to Reproduce:
1. Run top
2. Observe the totals
  
Actual results:

Top gives displays like this:
CPU states:  cpu    user    nice  system    irq  softirq  iowait    
idle
           total    0.0%    0.0%   28.4%   0.0%     0.0%    0.0%  
371.2%
           cpu00    0.0%    0.0%    0.0%   0.0%     0.0%    0.0%  
100.0%
           cpu01    0.0%    0.0%    0.0%   0.0%     0.0%    0.0%  
100.0%
           cpu02    0.0%    0.0%   33.3%   0.0%     0.0%    0.0%   
66.6%
           cpu03    0.0%    0.0%    0.0%   0.0%     0.0%    0.0%  
100.0%

Expected results:
Percentages should never go above 100%.

Additional info:
It appears that the problem here is that the "I" command is now 
toggled incorrectly for SMP systems.  With procps 2.0.13, running top 
produced a correct display, but with procps 2.0.17 it's necessary to 
execute the "I" command once to fix the display.  This default should 
set back to the old, correct behavior.
Comment 1 Karel Zak 2004-10-07 08:14:19 EDT

*** This bug has been marked as a duplicate of 132091 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.