Bug 134381 - defaults to personal calendar as unchecked.
Summary: defaults to personal calendar as unchecked.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 131589
TreeView+ depends on / blocked
 
Reported: 2004-10-01 21:04 UTC by Bill Peck
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 19:41:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Peck 2004-10-01 21:04:42 UTC
Description of problem:
personal calendar in Evolution defaults to being unchecked.  This is
non-intuitive because someone like me can attempt to create an
appointment but it won't work until you click the personal check box.

Version-Release number of selected component (if applicable):
2.0.1-2

How reproducible:
everytime

Steps to Reproduce:
1. start evolution from a virgin account
2. click on calendar
3. personal will be unchecked
4. Trying to create an appointment will result in no entries

  
Actual results:
no entry made

Expected results:
either a warning that no calendar is selected when trying to create an
appointment (or maybe ghost entries out), or/and? have the personal
calendar default to being checked on fresh install.

Additional info:

Comment 1 Dave Malcolm 2004-10-01 21:17:37 UTC
Calendars are stored in gconf in:
/apps/evolution/calendar/sources
(which stores a list of strings containing XML-ified data about each
calendar).

The state of those checkboxes appears to be determined by the UIDs
that appear in a list of strings in
/apps/evolution/calendar/display/selected_calendars

So I'm guessing that on a fresh install, upon going through the
startup wizard it generates the necessary stuff into GConf, and should
be adding it to that list, and isn't - will investigate further.

Comment 2 Dave Malcolm 2004-10-01 21:18:59 UTC
There's a patch upstream, will be fixed in 2.0.2

Comment 3 Dave Malcolm 2004-10-01 21:21:01 UTC
Upstream bug 61766; patch is on evolution-patches list, posted 28 Sep 2004

Comment 4 Alexander Larsson 2004-10-14 14:14:46 UTC
2.0.2 seems to be in now, is this fixed?

Comment 5 Dave Malcolm 2004-10-14 19:41:55 UTC
Yes: I just tried a fresh install of rawhide 20041014 with evo 2.0.2
and it's fixed.

Comment 6 Bill Peck 2004-10-14 19:48:33 UTC
confirmed as well.  yum update of evo 2.0.2 with a new user.

You just beat me to this Dave. :-) 


Note You need to log in before you can comment on or make changes to this bug.