Bug 1343835 - qtwebengine update problems.
Summary: qtwebengine update problems.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qtwebengine
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-08 06:59 UTC by eddy02
Modified: 2016-06-16 13:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 13:11:52 UTC
Type: Bug


Attachments (Terms of Use)

Description eddy02 2016-06-08 06:59:23 UTC
After updating qt5-qtwebengine (5.6.0-8.fc25),qupzilla shows only blank and blinking pages then crashes.

Downgrading qtwebengine solve the issue. 


 Time: mer. juin 8 08:35:10 2016
Qt version: 5.6.0 (compiled with 5.6.0)
QupZilla version: 2.0.0
Rendering engine: QtWebEngine

============== BACKTRACE ==============
#0: qupzilla(+0x3542) [0x55e4f4985542]
#1: /lib64/libc.so.6(+0x35950) [0x7f35f6394950]
#2: /lib64/libQt5Core.so.5(_ZN23QCoreApplicationPrivate29sendThroughObjectEventFiltersEP7QObjectP6QEvent+0xa7) [0x7f35f76a5957]
#3: /lib64/libQt5Widgets.so.5(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0x75) [0x7f35f84422f5]
#4: /lib64/libQt5Widgets.so.5(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x1017) [0x7f35f84482b7]
#5: /lib64/libQt5Core.so.5(_ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent+0xaa) [0x7f35f76a5bca]
#6: /lib64/libQt5Widgets.so.5(_ZN19QApplicationPrivate14sendMouseEventEP7QWidgetP11QMouseEventS1_S1_PS1_R8QPointerIS0_Eb+0x255) [0x7f35f8446a65]
#7: /lib64/libQt5Widgets.so.5(+0x1bb143) [0x7f35f84a1143]
#8: /lib64/libQt5Widgets.so.5(+0x1bd653) [0x7f35f84a3653]
#9: /lib64/libQt5Widgets.so.5(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0x9c) [0x7f35f844231c]
#10: /lib64/libQt5Widgets.so.5(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x25f) [0x7f35f84474ff]
#11: /lib64/libQt5Core.so.5(_ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent+0xaa) [0x7f35f76a5bca]
#12: /lib64/libQt5Gui.so.5(_ZN22QGuiApplicationPrivate17processMouseEventEPN29QWindowSystemInterfacePrivate10MouseEventE+0x753) [0x7f35f7eecd93]
#13: /lib64/libQt5Gui.so.5(_ZN22QGuiApplicationPrivate24processWindowSystemEventEPN29QWindowSystemInterfacePrivate17WindowSystemEventE+0x135) [0x7f35f7eee4e5]
#14: /lib64/libQt5Gui.so.5(_ZN22QWindowSystemInterface22sendWindowSystemEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0xbb) [0x7f35f7eceb1b]
#15: /lib64/libQt5XcbQpa.so.5(+0x6ebb0) [0x7f35e949cbb0]
#16: /lib64/libglib-2.0.so.0(g_main_context_dispatch+0x15a) [0x7f35f53fa95a]
#17: /lib64/libglib-2.0.so.0(+0x49d10) [0x7f35f53fad10]
#18: /lib64/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x7f35f53fadbc]
#19: /lib64/libQt5Core.so.5(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x5f) [0x7f35f76f560f]
#20: /lib64/libQt5Core.so.5(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0xfa) [0x7f35f76a4a3a]
#21: /lib64/libQt5Core.so.5(_ZN16QCoreApplication4execEv+0x9c) [0x7f35f76ac5cc]
#22: qupzilla(+0x2ad7) [0x55e4f4984ad7]
#23: /lib64/libc.so.6(__libc_start_main+0xf1) [0x7f35f637f461]
#24: qupzilla(+0x2df9) [0x55e4f4984df9]

Comment 1 eddy02 2016-06-08 07:14:57 UTC
Testing chromium from copr give  nearly same results blank and white pages.

Comment 2 Rex Dieter 2016-06-08 11:53:42 UTC
The same (source) build works fine on f24, so the issue is likely some external issue specific to rawhide :(

If you could get a backtrace with debuginfo, it may help give some better clues.

Comment 3 Kevin Kofler 2016-06-11 22:11:51 UTC
I built qt5-qtwebengine-5.6.1 and qupzilla-2.0.1 for Rawhide, do these work any better?

Comment 4 eddy02 2016-06-12 08:27:24 UTC
Qupzilla hangs (nouveau driver fifo and dma errors) and qtwebengine segfaults later.

I'll revert to the nvidia blob and make a retry as since kernel-4.6 I can't run  qtwebengine with nouveau driver without crashing.

Thanks for your builds and sorry for my english.

Comment 5 eddy02 2016-06-16 09:30:05 UTC
Latest Rex koji build solve the issue.
Qupzilla works again.

Thanks very much.


Note You need to log in before you can comment on or make changes to this bug.