Bug 134384 - Loosing entitlement affiliation
Loosing entitlement affiliation
Status: CLOSED DUPLICATE of bug 140579
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Release (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Todd Sanders
Red Hat Satellite QA List
: FutureFeature, Triaged
Depends On:
  Show dependency treegraph
Reported: 2004-10-01 17:11 EDT by Preston Wade
Modified: 2010-02-24 15:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-10-23 17:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Preston Wade 2004-10-01 17:11:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.1.4322)

Description of problem:
It appears as if older servers whose entitlements expire, take 
entitlements from servers that were more recently registered.  I 
would think that an entitlement should be married to a particular box.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Register a box for a year on 9/10/2003
2.Register another box for a year on 4/1/2004
3.Box that was registered on 9/10/2003 takes the entitlement of the 
box that was registered on 4/1/2004.

Expected Results:  An entitlement should not be taken from a box that 
was more recently registered by a box that has an expired entitlement.

Additional info:
Comment 1 viawest 2004-12-20 18:33:53 EST
We've seen the same behaviour recently.  It looks like we're using RHN 3.6.1.  We had 7 
machines' entitlements expire at the first of the month.  All free entitlements were used to 
renew the machines' entitlements, and several of the most recently registered and entitled 
servers were unsubscribed from their channels and the entitlements applied elsewhere.  
Here are my line item suggestions after troubleshooting this event:

- disable automated unsubscription and reallocation of entitlements from newly registered 
machines to old expired machines.  I can hardly imagine when I would even want the 
option of this feature.  The result is the same either way (systems are left unentitled), and 
it seems more intuitive that I would be left with the older machines unentitled because 
warnings of expiration are already sent out via email.

- disable automated application of free entitlements for expired systems.  I'd like the 
option to be able to see which machines are no longer unentitled and then manually 
entitle them.  This can be critical when associating costs with specific machines.

- provide an aggregated view of system events logging, not just the events link under each 
system.  this could be used to identify which machines have expired and/or undergone 
subscription actions.  There is no way to currently view this type of information without 
looking at the details of each individual machine which is very ineffecient.

That should do it.  Let me know if you need any further information, or if that last request 
should be moved to a new RFE.

Comment 2 Fanny Augustin 2006-11-14 15:54:29 EST
Reassigning  bugs from gdk (old RHN engineering Manager) to tsanders (current
RHN engineering manager)
Comment 4 Amanda Carter 2008-10-23 17:10:30 EDT

*** This bug has been marked as a duplicate of bug 140579 ***

Note You need to log in before you can comment on or make changes to this bug.