Bug 1343880 - dnf.plugin.repoquery documentation should use/explain --alldeps
dnf.plugin.repoquery documentation should use/explain --alldeps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
:
: 1347105 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-08 04:33 EDT by Jonathan Wakely
Modified: 2016-10-04 14:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-21 10:38:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Wakely 2016-06-08 04:33:14 EDT
The repoquery plugin does not behave like the old yum repoquery tool unless you use --alldeps. This isn't obvious from either of the yum2dnf(8) or dnf.plugin.repoquery(8) man pages.

The dnf.plugin.repoquery(8) man page should show the use of --alldeps in the examples, otherwise people get confused why dnf repoquery gives no results for an equivalent /usr/bin/repoquery search.

The documentation of --alldeps is also not very clear what it does, so you have a poorly documented option that is essential for getting the traditional behaviour people are used to, but which isn't shown in any examples.
Comment 1 Jaroslav Mracek 2016-06-13 10:41:36 EDT
The problem is fixed by pull-request: https://github.com/rpm-software-management/dnf/pull/505
Comment 2 Jaroslav Mracek 2016-06-20 08:02:32 EDT
*** Bug 1347105 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Admin XMLRPC Client 2016-07-08 05:39:34 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Igor Gnatenko 2016-07-21 10:38:01 EDT
Fixed as part of DNF 2.0 which will be availabla at some point soon.

Note You need to log in before you can comment on or make changes to this bug.