Bug 134389 - An "interesting" choice for a default mouse device in /etc/init.d/gpm
Summary: An "interesting" choice for a default mouse device in /etc/init.d/gpm
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gpm   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-10-01 22:03 UTC by Michal Jaegermann
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 1.20.1-57
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 19:43:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2004-10-01 22:03:04 UTC
Description of problem:

In /etc/rc.d/init.d/gpm there is the following:

        if [ -z "$DEVICE" ]; then
            DEVICE="/dev/mouse"
        fi

With a switch to udev one will be hard pressed to find
/dev/mouse.  There could be /dev/input/mice, or even /dev/mouse0,
or something of that sort, but /dev/mouse is not that likely.

To makes things more exciting my mouse on a console used to work,
and now gpm shows green "[ OK ]" on a startup, but it stopped working
despite the fact that I do have DEVICE=/dev/input/mice in
/etc/sysconfig/gpm and this is even a correct one.  It turns out
that the following piece of a code from a startup file is responsible:

if test -e /etc/sysconfig/mouse
then
    source /etc/sysconfig/mouse
    MOUSECFG=/etc/sysconfig/mouse
elif test -e /etc/sysconfig/gpm
then
    source /etc/sysconfig/gpm
    MOUSECFG=/etc/sysconfig/gpm
fi

and /etc/sysconfig/mouse was present on a system but with
no DEVICE defined in it.  Sigh!  If the above would be instead

if test -e /etc/sysconfig/mouse
then
    source /etc/sysconfig/mouse
    MOUSECFG=/etc/sysconfig/mouse
fi
if test -e /etc/sysconfig/gpm
then
    source /etc/sysconfig/gpm
    MOUSECFG=/etc/sysconfig/gpm
fi

then we would get at least the last definition instead of none.

Version-Release number of selected component (if applicable):
gpm-1.20.1-54

How reproducible:
Depends on what is in /etc/sysconfig (in mysterious ways if
you cannot read a shell code).


Note You need to log in before you can comment on or make changes to this bug.