Bug 1343897 - Optimize multiple removal of networks from DC while they are attached to host NIC via label
Summary: Optimize multiple removal of networks from DC while they are attached to host...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.0.0
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.3.0
: ---
Assignee: Alona Kaplan
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-08 09:17 UTC by Michael Burman
Modified: 2018-12-12 10:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-12 10:46:46 UTC
oVirt Team: Network
rule-engine: ovirt-4.3+


Attachments (Terms of Use)
engine log (203.26 KB, application/x-gzip)
2016-06-08 09:17 UTC, Michael Burman
no flags Details

Description Michael Burman 2016-06-08 09:17:38 UTC
Created attachment 1165871 [details]
engine log

Description of problem:
Optimize multiple removal of networks from DC while they are attached to host NIC via label. 

Currently, if we have multiple networks attached to NIC via label(let say 3) and we removing the networks from DC at once, the result will be:
That engine will try to perform 3 setup networks commands(instead of 1) on the same host simultaneously, so the first one will take the lock and all the other will fail. 
As a result 1 network will be removed from the server and the others will remain as 'unmanaged' networks on the host. 

- We should optimize such scenario/behavior and it should be considered as 1 setup networks command, the same optimization we have for the manage clusters, when detaching multiple networks from the cluster. 

Version-Release number of selected component (if applicable):
4.0.0.2-0.1.el7ev

How reproducible:
100

Steps to Reproduce:
1. Attach 3 vlan networks to NIC via label 
2. Remove the 3 networks from DC at once

Actual results:
3 setup networks command are sent.
first network removed, 2 other became 'unmanaged' 

Expected results:
1 setup networks command should be sent, like with manage clusters. 
All 3 networks should remove from the host(cause they attached via label)

Comment 1 Yaniv Kaul 2016-06-08 15:33:02 UTC
Is this a bug or a RFE?

Comment 2 Michael Burman 2016-06-09 05:18:24 UTC
It's a bug as i see it. But, it was never implemented, although it is the right behavior for such use case/scenario. 
Feel free to decide which one of them it is)

Comment 3 lgh 2018-05-16 13:28:12 UTC
i'm getting hit by the same problem, but when deleting multiple interfaces in a batch.

It really looks like a bug to me, since I would have expected to have all the networks removed  without any problems.

Comment 4 Dan Kenigsberg 2018-12-12 10:46:46 UTC
We are unlikely to implement this improvement soon.


Note You need to log in before you can comment on or make changes to this bug.