Bug 134390 - kernel sees only first two sata drives
kernel sees only first two sata drives
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-01 18:04 EDT by Matt Matolcsi
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-13 17:40:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Matolcsi 2004-10-01 18:04:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
This is a Dell Precision 370 using the Intel ICH6R (Intel 82801FR)
controller. Although both the BIOS and GRUB see three SATA drives,
once booted, the system recognizes only two of them. The controller is
currently in ATA compatibility mode because FC2 would not recognize
any drives at all when AHCI mode was enabled. 

I tried to recompile the kernel but it threw an error about not being
able to find an initrd image during 'make install', and I'm not
familiar enough with FC2 to go further. Any help would be greatly
appreciated. 


Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358smp

How reproducible:
Always

Steps to Reproduce:
1. Place the ICH6R controller in ATA compatibility mode.
2. Boot FC2, either uniprocessor or SMP kernel. 

    

Actual Results:  Only /dev/sda and /dev/sdb show up. 

Expected Results:  All SATA drives attached to the controller should
show up. There are 4 SATA channels available on this machine, 3 of
which have harddrives on them. 

Additional info:

In the source code for ata_piix.c, there is a statement about 33% of
the way in that defines offsets for two controllers, but only two and
not more. Is the driver written to only address two controllers?
Comment 1 Matt Matolcsi 2004-10-13 17:40:42 EDT
Upgrading to the 2.6.8 kernel has fixed this issue. Thanks FC2 team!

Note You need to log in before you can comment on or make changes to this bug.