Bug 134391 - yum a bit confused about obsoletes
yum a bit confused about obsoletes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-01 18:22 EDT by Michal Jaegermann
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 16:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-10-01 18:22:52 EDT
Description of problem:

In recent updates I used '--obsoletes' flag and yum found that
I had on a system 'fam-2.6.10-11.i386' about which I forgot when
switching x86_64 related packages to gamin replacements.  That is
fine but when showing what is going to do yum printed:

                [o] fam.i386 0:2.6.10-11 - gamin.x86_64 0:0.0.12-1

This seems to be actually cosmetics, although a bit confusing,
because when I later checked update results then I found that I have
on a system

gamin-0.0.12-1.i386
gamin-0.0.12-1.x86_64
gamin-devel-0.0.12-1.x86_64

Still when finishing the whole transaction yum dumped on my screen
a mysterious:
                 [o] fam.i386 0:2.6.10-11 - gamin.x86_64 0:0.0.12-1  
             [o] fam.i386 0:2.6.10-11 - gamin.x86_64 0:0.0.12-1      
    [o] fam.i386 0:2.6.10-11 - gamin.x86_64 0:0.0.12-1

???  The last two were really in one line (which may not show up when
reformatted by bugzilla).  Debugging leftovers?

Version-Release number of selected component (if applicable):
yum-2.1.4-1

How reproducible:
Difficult to check once updates were done.
Comment 1 Jeremy Katz 2005-07-29 16:02:35 EDT
This should be better in newer versions of yum.

Note You need to log in before you can comment on or make changes to this bug.