Bug 1343918 - Update fails trying to work with openstack-keystone pacemaker resource
Summary: Update fails trying to work with openstack-keystone pacemaker resource
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Jiri Stransky
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1333976
TreeView+ depends on / blocked
 
Reported: 2016-06-08 10:18 UTC by Jiri Stransky
Modified: 2016-08-11 11:32 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-heat-templates-2.0.0-11.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 11:32:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC
OpenStack gerrit 326631 None None None 2016-06-08 10:20:49 UTC
Launchpad 1590004 None None None 2016-06-08 10:18:31 UTC

Description Jiri Stransky 2016-06-08 10:18:32 UTC
Description of problem:

Minor update of overcloud fails with:

Error: Resource 'openstack-keystone-clone' does not exist

(visible in journalctl -u os-collect-config on the node being updated, or in `heat deployment-output-show --all <failed software deployment id>`)

Comment 1 Jiri Stransky 2016-06-08 10:20:50 UTC
Backport that solves this submitted against stable/mitaka.

Comment 5 Omri Hochman 2016-07-26 21:17:09 UTC
unable to reproduce with : openstack-tripleo-heat-templates-2.0.0-18.el7ost.noarch




stack@instack ~]$ heat stack-list
/usr/lib/python2.7/site-packages/requests/packages/urllib3/connection.py:303: SubjectAltNameWarning: Certificate for 192.0.2.2 has no `subjectAltName`, falling back to check for a `commonNam
e is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)
  SubjectAltNameWarning
WARNING (shell) "heat stack-list" is deprecated, please use "openstack stack list" instead
/usr/lib/python2.7/site-packages/requests/packages/urllib3/connection.py:303: SubjectAltNameWarning: Certificate for 192.0.2.2 has no `subjectAltName`, falling back to check for a `commonNam
e is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)
  SubjectAltNameWarning
+--------------------------------------+------------+-----------------+---------------------+---------------------+
| id                                   | stack_name | stack_status    | creation_time       | updated_time        |
+--------------------------------------+------------+-----------------+---------------------+---------------------+
| db74c61a-3135-4405-b10c-a716d8460095 | overcloud  | UPDATE_COMPLETE | 2016-07-26T17:49:40 | 2016-07-26T19:03:52 |
+--------------------------------------+------------+-----------------+---------------------+---------------------+

Comment 8 errata-xmlrpc 2016-08-11 11:32:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.