Bug 1343956 - Cannot connect to Teiid if server runs on JVM 1.6
Summary: Cannot connect to Teiid if server runs on JVM 1.6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ER5
: 6.3.0
Assignee: Van Halbert
QA Contact: Juraj Duráni
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-08 11:58 UTC by Juraj Duráni
Modified: 2016-08-24 11:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
JVM 1.6
Last Closed: 2016-08-24 11:45:49 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker TEIID-4258 Blocker Closed Cannot connect to Teiid if server runs on JVM 1.6 2019-09-26 17:16:51 UTC

Description Juraj Duráni 2016-06-08 11:58:54 UTC
If Teiid runs on JVM 1.6. connection fails with EOFException [1]

[1] Exception thrown (used squirrel client)
java.util.concurrent.ExecutionException: java.lang.RuntimeException: org.teiid.jdbc.TeiidSQLException: TEIID20020 Error establishing socket to host and port: localhost:31000. Reason: null
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:206)
	at net.sourceforge.squirrel_sql.client.mainframe.action.OpenConnectionCommand.awaitConnection(OpenConnectionCommand.java:132)
	at net.sourceforge.squirrel_sql.client.mainframe.action.OpenConnectionCommand.access$100(OpenConnectionCommand.java:45)
	at net.sourceforge.squirrel_sql.client.mainframe.action.OpenConnectionCommand$2.run(OpenConnectionCommand.java:115)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:744)
Caused by: java.lang.RuntimeException: org.teiid.jdbc.TeiidSQLException: TEIID20020 Error establishing socket to host and port: localhost:31000. Reason: null
	at net.sourceforge.squirrel_sql.client.mainframe.action.OpenConnectionCommand.executeConnect(OpenConnectionCommand.java:171)
	at net.sourceforge.squirrel_sql.client.mainframe.action.OpenConnectionCommand.access$000(OpenConnectionCommand.java:45)
	at net.sourceforge.squirrel_sql.client.mainframe.action.OpenConnectionCommand$1.run(OpenConnectionCommand.java:104)
	... 5 more
Caused by: org.teiid.jdbc.TeiidSQLException: TEIID20020 Error establishing socket to host and port: localhost:31000. Reason: null
	at org.teiid.jdbc.TeiidSQLException.create(TeiidSQLException.java:135)
	at org.teiid.jdbc.TeiidSQLException.create(TeiidSQLException.java:71)
	at org.teiid.jdbc.SocketProfile.connect(SocketProfile.java:66)
	at org.teiid.jdbc.TeiidDriver.connect(TeiidDriver.java:107)
	at org.teiid.jdbc.TeiidDriver.connect(TeiidDriver.java:55)
	at net.sourceforge.squirrel_sql.fw.sql.SQLDriverManager.getConnection(SQLDriverManager.java:133)
	at net.sourceforge.squirrel_sql.client.mainframe.action.OpenConnectionCommand.executeConnect(OpenConnectionCommand.java:167)
	... 7 more
Caused by: org.teiid.net.socket.SingleInstanceCommunicationException: TEIID20020 Error establishing socket to host and port: localhost:31000. Reason: null
	at org.teiid.net.socket.SocketServerConnection.selectServerInstance(SocketServerConnection.java:161)
	at org.teiid.net.socket.SocketServerConnection.<init>(SocketServerConnection.java:95)
	at org.teiid.net.socket.SocketServerConnectionFactory.getConnection(SocketServerConnectionFactory.java:316)
	at org.teiid.jdbc.SocketProfile.connect(SocketProfile.java:64)
	... 11 more
Caused by: java.io.EOFException
	at java.io.DataInputStream.readInt(DataInputStream.java:392)
	at org.teiid.netty.handler.codec.serialization.ObjectDecoderInputStream.readObjectOverride(ObjectDecoderInputStream.java:97)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:365)
	at org.teiid.net.socket.OioOjbectChannelFactory$OioObjectChannel.read(OioOjbectChannelFactory.java:117)
	at org.teiid.net.socket.SocketServerInstanceImpl.doHandshake(SocketServerInstanceImpl.java:128)
	at org.teiid.net.socket.SocketServerInstanceImpl.connect(SocketServerInstanceImpl.java:96)
	at org.teiid.net.socket.SocketServerConnectionFactory.getServerInstance(SocketServerConnectionFactory.java:277)
	at org.teiid.net.socket.SocketServerConnection.connect(SocketServerConnection.java:239)
	at org.teiid.net.socket.SocketServerConnection.selectServerInstance(SocketServerConnection.java:125)
	... 14 more

Comment 1 JBoss JIRA Server 2016-06-08 15:06:38 UTC
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-4258 to Coding In Progress

Comment 2 JBoss JIRA Server 2016-06-08 18:00:32 UTC
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-4258 to Resolved

Comment 3 JBoss JIRA Server 2016-07-01 16:29:09 UTC
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-4258 to Closed


Note You need to log in before you can comment on or make changes to this bug.