Bug 1343976 - s2i build error (node-gyp)
Summary: s2i build error (node-gyp)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: node-gyp
Version: rh-nodejs4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: alpha
: 2.2
Assignee: Zuzana Svetlikova
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On: 1342088
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-08 12:27 UTC by Zuzana Svetlikova
Modified: 2016-06-21 07:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1342088
Environment:
Last Closed: 2016-06-21 07:27:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1263 normal SHIPPED_LIVE new packages: rh-nodejs4 2016-06-21 11:18:57 UTC

Description Zuzana Svetlikova 2016-06-08 12:27:34 UTC
+++ This bug was initially created as a clone of Bug #1342088 +++

Description :
Using the s2i build with the  registry.access.redhat.com/openshift3/nodejs-010-rhel7 image , and a simple application using contextify@0.1.15  


Version-Release number of selected component (if applicable):
using s2i v1.0.9
registry.access.redhat.com/openshift3/nodejs-010-rhel7:latest
contextify@0.1.15 


How reproducible: Always


Steps to Reproduce:

The command I used was  ~/Programs/s2i build . registry.access.redhat.com/openshift3/nodejs-010-rhel7 test-appDescription  

Actual results:

E0527 09:46:09.907861 23474 util.go:91] Traceback (most recent call last):
E0527 09:46:09.907883 23474 util.go:91]   File "/opt/rh/v8314/root/usr/bin/gyp", line 9, in <module>
E0527 09:46:09.907888 23474 util.go:91]     load_entry_point('gyp==0.1', 'console_scripts', 'gyp')()
E0527 09:46:09.907893 23474 util.go:91]   File "/opt/rh/v8314/root/usr/lib/python2.7/site-packages/gyp/__init__.py", line 532, in script_main
E0527 09:46:09.910201 23474 util.go:91]     return main(sys.argv[1:])
E0527 09:46:09.910214 23474 util.go:91]   File "/opt/rh/v8314/root/usr/lib/python2.7/site-packages/gyp/__init__.py", line 525, in main
E0527 09:46:09.910404 23474 util.go:91]     return gyp_main(args)
E0527 09:46:09.910421 23474 util.go:91]   File "/opt/rh/v8314/root/usr/lib/python2.7/site-packages/gyp/__init__.py", line 501, in gyp_main
E0527 09:46:09.910699 23474 util.go:91]     params, options.check, options.circular_check)
E0527 09:46:09.910707 23474 util.go:91]   File "/opt/rh/v8314/root/usr/lib/python2.7/site-packages/gyp/__init__.py", line 128, in Load
E0527 09:46:09.910716 23474 util.go:91]     params['parallel'], params['root_targets'])
E0527 09:46:09.910721 23474 util.go:91]   File "/opt/rh/v8314/root/usr/lib/python2.7/site-packages/gyp/input.py", line 2736, in Load
E0527 09:46:09.912483 23474 util.go:91]     variables, includes, depth, check, True)
E0527 09:46:09.912553 23474 util.go:91]   File "/opt/rh/v8314/root/usr/lib/python2.7/site-packages/gyp/input.py", line 386, in LoadTargetBuildFile
E0527 09:46:09.912735 23474 util.go:91]     includes, True, check)
E0527 09:46:09.912745 23474 util.go:91]   File "/opt/rh/v8314/root/usr/lib/python2.7/site-packages/gyp/input.py", line 238, in LoadOneBuildFile
E0527 09:46:09.912817 23474 util.go:91]     None)
E0527 09:46:09.914237 23474 util.go:91]   File "/opt/rh/v8314/root/usr/bin/gyp", line 3
E0527 09:46:09.914286 23474 util.go:91]     __requires__ = 'gyp==0.1'
E0527 09:46:09.914289 23474 util.go:91]                  ^
E0527 09:46:09.914292 23474 util.go:91] SyntaxError: invalid syntax
E0527 09:46:09.919898 23474 util.go:91] gyp ERR! configure error

Expected results:


Additional info:

Comment 1 Zuzana Svetlikova 2016-06-08 13:34:49 UTC
contextify is now part of Node, but building other modules still fails with similar error.

Traceback (most recent call last):
  File "/opt/rh/rh-nodejs4/root/usr/bin/gyp", line 18, in <module>
    sys.exit(gyp.main(sys.argv[1:]))
  File "/opt/rh/rh-nodejs4/root/usr/lib/python2.7/site-packages/gyp/__init__.py", line 525, in main
    return gyp_main(args)
  File "/opt/rh/rh-nodejs4/root/usr/lib/python2.7/site-packages/gyp/__init__.py", line 501, in gyp_main
    options.circular_check)
  File "/opt/rh/rh-nodejs4/root/usr/lib/python2.7/site-packages/gyp/__init__.py", line 130, in Load
    params['parallel'])
  File "/opt/rh/rh-nodejs4/root/usr/lib/python2.7/site-packages/gyp/input.py", line 2572, in Load
    variables, includes, depth, check, True)
  File "/opt/rh/rh-nodejs4/root/usr/lib/python2.7/site-packages/gyp/input.py", line 363, in LoadTargetBuildFile
    includes, True, check)
  File "/opt/rh/rh-nodejs4/root/usr/lib/python2.7/site-packages/gyp/input.py", line 218, in LoadOneBuildFile
    None)
  File "/opt/rh/rh-nodejs4/root/usr/bin/gyp", line 7
    import sys
         ^
SyntaxError: invalid syntax
gyp ERR! configure error

Comment 5 errata-xmlrpc 2016-06-21 07:27:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1263


Note You need to log in before you can comment on or make changes to this bug.