Bug 1343979 - CLI overcloud update interactive mode doesn't work
Summary: CLI overcloud update interactive mode doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
urgent
unspecified
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Jiri Stransky
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks: 1333976
TreeView+ depends on / blocked
 
Reported: 2016-06-08 12:30 UTC by Jiri Stransky
Modified: 2016-08-11 11:32 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-common-2.0.0-6.el7ost.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 11:32:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC
OpenStack gerrit 328260 None None None 2016-06-10 12:29:46 UTC
OpenStack gerrit 328915 None None None 2016-06-13 09:53:34 UTC
Launchpad 1589986 None None None 2016-06-08 12:30:53 UTC

Description Jiri Stransky 2016-06-08 12:30:53 UTC
Description of problem:

When performing minor update in interactive mode, the command exits immediately:

[stack@instack ~]$ openstack overcloud update stack overcloud --templates -i
starting package update on stack overcloud
COMPLETE
update finished with status COMPLETE

See the linked upstream bug for more info.


Version-Release number of selected component (if applicable):

python-tripleoclient-2.0.0-1.0.2.el7ost.noarch
openstack-tripleo-heat-templates-kilo-2.0.0-8.el7ost.noarch
openstack-tripleo-0.0.8-0.2.d81bd6dgit.el7ost.noarch
openstack-tripleo-puppet-elements-2.0.0-2.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-8.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-8.el7ost.noarch
openstack-tripleo-common-2.0.0-5.el7ost.noarch
openstack-tripleo-image-elements-0.9.9-3.el7ost.noarch

How reproducible:

The error seems to be intermittent but appears more often than not. After a couple of tries for a minor update CLI went to the interactive phase fine. It's likely some kind of a race condition.

Comment 1 Jiri Stransky 2016-06-08 12:33:17 UTC
`openstack overcloud update stack overcloud -i --templates` on a deployed OSP 9 should reproduce this intermittently, but with high likelyhood.

Comment 3 Alexander Chuzhoy 2016-07-26 19:47:33 UTC
Verified:
Environment:
openstack-tripleo-common-2.0.0-6.el7ost.noarch

[stack@undercloud ~]$ openstack overcloud update stack overcloud -i --templates -e /usr/share/openstack-tripleo-heat-templates/overcloud-resource-registry-puppet.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml    -e network-environment.yaml
starting package update on stack overcloud
WAITING
not_started: [u'overcloud-controller-1', u'overcloud-cephstorage-0', u'overcloud-compute-0', u'overcloud-controller-2', u'overcloud-controller-0']
on_breakpoint: [u'overcloud-cephstorage-1']
Breakpoint reached, continue? Regexp or Enter=proceed (will clear 52983a46-d38b-4642-a269-71d74441bf77), no=cancel update, C-c=quit interactive mode:

Comment 6 errata-xmlrpc 2016-08-11 11:32:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.