Bug 1344006 - Can't update CA certificate for existing oVirt compute resource
Summary: Can't update CA certificate for existing oVirt compute resource
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Kedar Bidarkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-08 13:29 UTC by Marek Hulan
Modified: 2019-09-26 14:37 UTC (History)
3 users (show)

Fixed In Version: foreman-1.11.0.39-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:02:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 15345 0 None None None 2016-06-08 13:29:35 UTC

Description Marek Hulan 2016-06-08 13:29:33 UTC
When an oVirt CR is created, it saves public key of CA that issues the certificate for oVirt in attrs[:public_key]. In 1.7.0 there was added a new text-area so user can set the CA cert manually in the form. There's also public_key hidden field that was used before to keep public_key on updates if there was already some data center loaded. Since it's after the text area, it always overrides its value which is a problem when editing the CR.

Steps to reproduce:
1. create oVirt CR, make sure it has public key stored
2. change the CA/self-signed certificate on oVirt instance
3. edit the CR in Foreman, delete old public key in text area and try hitting load datacenters/test connection button

Result:
you'll see that the request fails on SSL issue, if you check the text area, you can see that the public key is reset to the old value

Expected:
it should load new public key and sucessfuly load data centers

Comment 1 Marek Hulan 2016-06-08 13:29:37 UTC
Created from redmine issue http://projects.theforeman.org/issues/15345

Comment 2 Marek Hulan 2016-06-08 13:29:41 UTC
Upstream bug assigned to mhulan@redhat.com

Comment 3 Bryan Kearney 2016-06-13 12:17:13 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/15345 has been closed

Comment 5 Bryan Kearney 2016-07-27 11:02:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.