Bug 1344023 - Upgrades are not migrating several capsule answers/parameters
Summary: Upgrades are not migrating several capsule answers/parameters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Sachin Ghai
URL:
Whiteboard:
: 1344384 (view as bug list)
Depends On:
Blocks: 1335807
TreeView+ depends on / blocked
 
Reported: 2016-06-08 14:28 UTC by Brad Buckingham
Modified: 2019-09-26 17:32 UTC (History)
3 users (show)

Fixed In Version: satellite-installer-6.2.0.10-1,katello-installer-base-3.0.0.45-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:27:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 15350 0 None None None 2016-06-08 15:11:16 UTC
Foreman Issue Tracker 15390 0 None None None 2016-06-13 18:07:10 UTC

Description Brad Buckingham 2016-06-08 14:28:48 UTC
Description of problem:

When upgrading a Satellite or an external Capsule from 6.1 to 6.2, there are several parameters that are not getting migrated from the old configuration [1] to the new configuration [2].

This includes parameters such as:

    bmc
    bmc_default_provider
    dhcp
    dhcp_listen_on
    dhcp_option_domain
    dhcp_managed
    dhcp_interface
    dhcp_gateway
    dhcp_range
    dhcp_nameservers
    dhcp_vendor
    dhcp_config
    dhcp_leases
    dhcp_key_name
    dhcp_key_secret
    dns
    dns_managed
    dns_provider
    dns_zone
    dns_reverse
    dns_interface
    dns_server
    dns_ttl
    dns_tsig_keytab
    dns_tsig_principal
    dns_forwarders
    virsh_network
    realm
    realm_provider
    realm_keytab
    realm_principal
    freeipa_remove_dns
    register_in_foreman

Version-Release number of selected component (if applicable):

Satellite 6.2 SNAP 14

How reproducible:

Always

Steps to Reproduce:
1. Install Satellite 6.1 and Capsule 6.1
2. Ensure that the configuration has several foreman proxy services configured with non-default values (e.g. dns, dhcp, realm, bnc...)
3. Upgrade the Satellite to 6.2
4. Upgrade the Capsule to 6.2

Actual results:

Upgrade may fail; however, observe that the answers file generated for the upgraded environment does not indicated that the previous configuration was migrated.

See [2] for the new files.

Expected results:

The answers from should be migrated from [1] to [2] and used as part of the upgrade process.

Additional info:

[1] /etc/katello-installer/answers.katello-installer.yaml (internal capsule)
    /etc/capsule-installer/answers.capsule-installer.yaml (external capsule)

[2] /etc/foreman-installer/scenarios.d/satellite-answers.yaml (internal capsule)
    /etc/foreman-installer/scenarios.d/capsule-answers.yaml (external capsule)

Comment 1 Brad Buckingham 2016-06-08 15:11:15 UTC
Created redmine issue http://projects.theforeman.org/issues/15350 from this bug

Comment 3 Brad Buckingham 2016-06-08 21:19:34 UTC
Note: this bug will require both the upstream PR and downstream MR..

Comment 4 Brad Buckingham 2016-06-09 13:14:47 UTC
As a workaround, if any of the fields noted in the original description are in use on either the Satellite internal capsule or external Capsule, the values can be provided as an input during the upgrade. 

E.g. enabling bmc on an external capsule

satellite-installer --scenario capsule --upgrade --bmc true

To view the list of options available prior to upgrade execute:
   satellite-installer --scenario satellite --help
   satellite-installer --scenario capsule --help

Comment 5 Brad Buckingham 2016-06-09 19:38:20 UTC
*** Bug 1344384 has been marked as a duplicate of this bug. ***

Comment 6 Bryan Kearney 2016-06-13 20:16:06 UTC
Upstream bug assigned to ehelms@redhat.com

Comment 7 Bryan Kearney 2016-06-13 20:16:08 UTC
Upstream bug component is Installer

Comment 8 Bryan Kearney 2016-06-13 20:16:11 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/15390 has been closed

Comment 9 Sachin Ghai 2016-06-20 09:27:11 UTC
Verified issue with upgrade from sat6.1.9 -> sat6.2 GA snap16 on rhel7:

Issue has been reolved for internal/default capsule. I can see upgrades are now migarating the capsule answers parameters. I can see dns/dhcp/bmc features enabled on default capsule after migration. Earlier they got disabled. I can see all param correctly populated under: 

"/etc/foreman-installer/scenarios.d/satellite-answers.yaml"

Comment 11 Sachin Ghai 2016-06-20 10:10:50 UTC
I can see dns/dhcp/bmc features enabled on external capsule after migration and answer file for capsule is correctly populated.

Comment 13 Bryan Kearney 2016-07-27 11:27:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.