Bug 1344038 - SSL enabled undercloud doesn't configure https protocol for the ironic-inspector endpoint
Summary: SSL enabled undercloud doesn't configure https protocol for the ironic-inspec...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-ironic
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Juan Antonio Osorio
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-08 15:04 UTC by Marius Cornea
Modified: 2016-12-14 15:36 UTC (History)
17 users (show)

Fixed In Version: puppet-ironic-9.4.0-1.el7ost puppet-tripleo-5.2.0-1.el7ost openstack-mistral-3.0.0-0.20160929083341.c0a4501.el7ost instack-undercloud-4.0.0-14.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:36:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 332640 None None None 2016-07-06 13:58:18 UTC
OpenStack gerrit 332641 None None None 2016-07-06 13:56:41 UTC
OpenStack gerrit 343292 None None None 2016-07-18 04:39:19 UTC
OpenStack gerrit 349968 None None None 2016-09-23 14:18:58 UTC

Description Marius Cornea 2016-06-08 15:04:36 UTC
Description of problem:
SSL enabled undercloud doesn't configure https protocol for the ironic-inspector endpoint

Version-Release number of selected component (if applicable):
instack-undercloud-4.0.0-2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy undercloud with ssl
2. openstack catalog show ironic-inspector
3.

Actual results:
+-----------+----------------------------------------+
| Field     | Value                                  |
+-----------+----------------------------------------+
| endpoints | regionOne                              |
|           |   publicURL: http://192.168.0.1:5050   |
|           |   internalURL: http://192.168.0.1:5050 |
|           |   adminURL: http://192.168.0.1:5050    |
|           |                                        |
| name      | ironic-inspector                       |
| type      | baremetal-introspection                |
+-----------+----------------------------------------+


Expected results:
publicURL: https://192.168.0.1:5050

Additional info:

Comment 2 Juan Antonio Osorio 2016-06-21 15:46:16 UTC
I can work on this. for what releases should this be done? OSP9 and 10 or should I also backport it to OSP8?

Comment 10 Juan Antonio Osorio 2016-08-03 05:11:12 UTC
I was finally able to reproduce this issue. And it turns out we uncovered an issue with Mistral. I have submitted a fix [1] for the mistral issue which should finally unblock this for Newton. Mitaka didn't have this issue.

[1] https://review.openstack.org/#/c/349968/

Comment 11 Nathan Kinder 2016-09-02 20:56:08 UTC
Ozz - I believe that you have fixed this upstream.  Has the fix been pulled into a downstream build yet?  If so, please set the package N-V-R in the "Fixed In Version" field and set this bug to MODIFIED.

Comment 12 Juan Antonio Osorio 2016-09-12 11:20:46 UTC
It hasn't been pulled downstream. It is fixed upstream, however.

Comment 14 Marius Cornea 2016-11-28 13:52:27 UTC
[stack@undercloud-0 ~]$  openstack catalog show ironic-inspector
+-----------+----------------------------------------+
| Field     | Value                                  |
+-----------+----------------------------------------+
| endpoints | regionOne                              |
|           |   publicURL: https://192.168.0.2:13050 |
|           |   internalURL: http://192.168.0.1:5050 |
|           |   adminURL: http://192.168.0.1:5050    |
|           |                                        |
| name      | ironic-inspector                       |
| type      | baremetal-introspection                |
+-----------+----------------------------------------+

Comment 16 errata-xmlrpc 2016-12-14 15:36:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.