Bug 1344042 - LibreOffice Writer mouse wheel scrolling doesn't scroll far enough on each wheel event
Summary: LibreOffice Writer mouse wheel scrolling doesn't scroll far enough on each wh...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-08 15:13 UTC by Assen Totin
Modified: 2016-07-19 15:51 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-07-19 15:51:53 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 826654 None None None 2016-06-09 11:01 UTC

Description Assen Totin 2016-06-08 15:13:50 UTC
Description of problem:
Mouse scrolling in LibreOffice Write is several times slower than in all other apps. "Slower" here means that much less lines of text (or screen area in general) is scrolled up/down for the same amount of mouse wheel rotation, compared to other applications (e.g., Firefox).

Version-Release number of selected component (if applicable):
libreoffice-5.1.3.2-6.fc24.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Open a multi-page ODF document in LibreOffice Writer (contents does not matter; text-only is fine).
2. Scroll using the mouse wheel. 

Actual results:
Page scrolls much slower than in other apps like Fiefox or notepad.

Expected results:
Scroll rate should be approximately the same as with any other app. 

Additional info:
LibreOffice is build against GTK3, but so is Firefox, which does not suffer from the issue. The problem was not present in previosu editions of LibreOffice that were build against GTK2. The above mentioned "notepad" is actually Pluma from MATE, which is also built against GTK3 (not a Fedora build) and scroll works properly in terms of speed.

Comment 1 Caolan McNamara 2016-06-09 10:43:35 UTC
I think I've heard this complaint before and its the use of the word "slow" which has thrown me off. Its not that scrolling is slow I think, but that scrolling with the wheel doesn't scroll "far enough" so less is scrolled rather than the scrolling is rendering slowly


Note You need to log in before you can comment on or make changes to this bug.