Bug 1344052 - Drop functionality doesn't work on .desktop files
Summary: Drop functionality doesn't work on .desktop files
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kde-baseapps
Version: 7.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1420851 1479818
TreeView+ depends on / blocked
 
Reported: 2016-06-08 15:26 UTC by jigar
Modified: 2018-10-26 07:58 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-10 11:31:43 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0717 None None None 2018-04-10 11:33 UTC

Description jigar 2016-06-08 15:26:00 UTC
Description of problem: Drop functionality on .desktop files only works when the user has write premission on the .desktop files. We can not give write support on these files. 

How reproducible: Always ( except on Desktop )

Steps to Reproduce:
1. Place .desktop files in /tmp or  /tmp or / usr/local/bin (eg. kwrite.desktop)
2. Try dropping files on these .desktop files (eg. abc.txt )
3. Check if the files open with the application

Actual results: The application doesn't launch without write permission

Expected results: The application should launch and file should open

Comment 4 Ajinkya Patil 2017-06-16 14:49:41 UTC
Greetings,

When can we expect a fix for this bug?

Thanks
Ajinkya Patil

Comment 5 Jan Grulich 2017-06-19 06:00:00 UTC
I will look into this issue for rhel-7.5.

Comment 9 Jan Grulich 2017-10-16 12:19:35 UTC
Fixed in kde-baseapps-4.10.5-5.el7.

Comment 14 errata-xmlrpc 2018-04-10 11:31:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0717


Note You need to log in before you can comment on or make changes to this bug.