This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 134408 - [FC3] gstreamer can't use 32-bit plugins on x86_64
[FC3] gstreamer can't use 32-bit plugins on x86_64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-10-01 21:05 EDT by Chris Ricker
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-14 16:41:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2004-10-01 21:05:43 EDT
Installing 20041001 tree on x86_64, I see

Installing gstreamer-0.8.5-1.i386.
error: %post(gstreamer-0.8.5-1) scriptlet failed, exit status 127
Installing gstreamer-0.8.5-1.x86_64.

(%post errors for i386, not for x86_64)
Comment 1 Colin Walters 2004-10-05 14:45:59 EDT
I suspect this has something to do with the registry conflicting. 
I'll investigate further.
Comment 2 Colin Walters 2004-10-06 11:02:39 EDT
I can't reproduce this, works fine for me on a fresh x86_64 rawhide
install.  Do you have any additional GStreamer plugins installed?  Say
perhaps the linva.org ones?

If you remove gstreamer-0.8.5-1.i386, do you get the error again?
If so, can you try removing the > /dev/null 2> /dev/null from the
postinst and reinstalling?
Comment 3 Bill Nottingham 2004-10-06 23:51:55 EDT
This is because gstreamer.i386 is being installed first, without
gst-register (as that will be provided by the x86-64 package.)
Comment 4 Colin Walters 2004-11-03 15:43:24 EST
It seems to me that gst-register is currently broken rather
fundamentally on multilib systems.  It has the same problem that e.g.
gdk-pixbuf-query-loaders had.  So my plan is:

1) move gst-register-0.8 binaries into /usr/libexec/gst-register-$ARCH
2) write a wrapper script /usr/bin/gst-register-0.8 which invokes
/usr/libexec/gst-register-{i386,x86_64}-redhat-linux-gnu.
3) move /var/cache/gstreamer/registry.xml into arch-specific versions,
  registry-{i386,x86_64}-redhat-linux-gnu.xml.
4) modify libgstreamer to look for the arch-specific registry.

Comment 5 Colin Walters 2004-11-09 17:58:54 EST
Ok, gstreamer-0.8.7-6 built into FC4.
Comment 6 Colin Walters 2004-11-09 17:59:38 EST
Err... didn't mean to close.
Comment 9 Colin Walters 2004-12-14 16:41:34 EST
This is fixed now by gstreamer-0.8.7-4.FC3.0.

Note You need to log in before you can comment on or make changes to this bug.