Bug 134413 - Recent Documents folder does not refresh
Recent Documents folder does not refresh
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-01 23:18 EDT by John MacLean
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 14:53:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John MacLean 2004-10-01 23:18:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040930
Firefox/0.10

Description of problem:
The Recent Documents folder under the gnome main menu is static no
matter how many file are opened/closed. Its own Clear Recent Documents
option does not result in a change. However, it does work if
nautilus/'File Browser' is open.

Version-Release number of selected component (if applicable):
gamin-0.0.12-1

How reproducible:
Always

Steps to Reproduce:
1.Open a file using a gnome app
2.Look for this file in Recent Documents menu
3.
    

Expected Results:  All files opened/saved from any gnome-aware apps
should appear in Recent Documents menu.

Additional info:

I) Baseline situation.
$ rpm -q gamin
gamin-0.0.12-1
$ ps ux | grep [g]am_server
john      9848  0.0  0.1  2856 1440 ?        S    22:05   0:00
/usr/libexec/gam_server
$ ls -l ~/.recently-used
-rw-------  1 john john 0 Oct  1 22:25 .recently-used
"Recent Documents" under the gnome main menu is grayed out and cannot
be selected.

All is ok at this point.

II) Open a file using gedit (or OpenOffice.org or just about any Gnome
aware app).
$ ls -l ~/.recently-used
-rw-------  1 john john 472 Oct  1 22:34 .recently-used
$ cat ~/.recently-used
<?xml version="1.0"?>
<RecentFiles>
  <RecentItem>
    <URI>file:///home/john/gamin-bug.txt</URI>
    <Mime-Type>text/plain</Mime-Type>
    <Timestamp>1096684302</Timestamp>
    <Groups>
      <Group>gedit</Group>
    </Groups>
  </RecentItem>
</RecentFiles>

~/.recently-used is updated. However, "Recent Documents" is still
grayed out.

III) If I log out and back in, then Recent Documents displays the file
previously opened. Selecting "Clear Recent Documents" from the bottom
of list does result in the ~/.recently-used being truncated to 0 bytes
but the previously opened file is still listed in the Recent Documents
menu (and the file links still work).

IV) Starting the File Browser/nautilus app 'fixes' the behaviour. The
Recent Documents menu is immediately updated to reflect the files
listed in ~/.recently-used. Any files opened or created by any other
app appear in the Recent Documents immediately. Clearing the list
takes effect immediately.

V) After closing File Browser, behaviour is inconsistent. Some new
files get listed, some don't. Clearing sometimes does and does not work.
Comment 1 Daniel Veillard 2004-10-03 14:53:22 EDT
I think I have found the source of the problem and fixed it in
gamin-0.0.14 available at:
http://www.gnome.org/~veillard/gamin/downloads.html

and which should show up soon on rawhide.

Daniel
Comment 2 John MacLean 2004-10-04 23:09:37 EDT
Daniel, 
It isn't quite fixed yet. Updated to gamin-0.0.14-1, logged out, made
sure no gam_server process running and logged back into gnome.

From gedit, using file open dialog box:
First file accessed, no change to Recent Documents.
Second file accessed, first file appears in Recent Documents.
Third file accessed, second file appears. 
Select Clear All Documents and no change. Selecting 'Clear All
Documents' repeatedly and still no change.
Access another file, then Recent Documents are cleared.

Looks like all events are being queued, but almost as if the 'signal'
is being ignored and the second signal process the first event.

With nautilus running (but not being used), the behaviour same as
above and therefore worse than gamin-0.0.12-1.

If the files are being opened from within nautilus (i.e.
double-clicking from the folder window) then the Recent Documents
folder is updated correctly.

Note You need to log in before you can comment on or make changes to this bug.