Bug 134421 - ALSA "pauses" for a couple seconds
ALSA "pauses" for a couple seconds
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-02 01:23 EDT by Erich Hoover
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-17 05:13:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erich Hoover 2004-10-02 01:23:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; rv:1.7.3)
Gecko/20040930 Firefox/0.10

Description of problem:
About every 5-25 minutes ALSA "pauses" the audio for a couple seconds
(which can be really annoying if you are presenting a video).  The
weird thing is the way the audio pauses, whatever program is playing
the program will continue playing uninterrupted but nothing comes out.
 There are also no error messages generated in any of the log files
(dmesg, messages, secure).  I don't believe this is a hardware problem
because it is too consistent (and I haven't messed with anything
between when it worked and when it didn't) and it appeared to start
after the most recent update to alsa-libs a little while back.

Version-Release number of selected component (if applicable):
alsa-lib-1.0.6-1

How reproducible:
Always

Steps to Reproduce:
1. Update everything
2. Run an audio program (XMMS, CD Player, MPlayer, Xine, or otherwise)
3. Set the audio program to use ALSA or OSS emulation, it doesn't matter
4. Play audio while you work on things or browse the web (or you just
play the audio program and don't touch anything else)


Actual Results:  Audio "pauses" every few minutes for about two seconds.

Expected Results:  The audio shouldn't have paused.

Additional info:

System:
Sound Blaster Live! Platinum (EMU10K1 chipset)
ASUS SK8N
AMD FX-53
Corsair PC-2700 RAM
GeForce 6800 w/ nvidia driver
WD740GD SATA Drive
Comment 1 Andy Green 2005-01-06 08:11:54 EST
Seeing something very similar, but my kit is very different.  
  
I assumed this was a kernel problem, not alsa-lib.  
  
Epia-M 1GHz  
Linux version 2.6.10-1.1056_FC4  
(bhcompile@decompose.build.redhat.com) (gcc version 3.4.3 20041226  
(Red Hat 3.4.3-11)) #1 Thu Dec 30 23:48:33 EST 2004  
Using ALSA, but on a snd_via82xx module  
Via built-in shared-memory video  
  
Again the problem is seen on video playback, a pause of two seconds  
or so at fairly long intervals, many minutes.  It is sort of like  
mplayer is on a nice 19 (it isn't) and something important is 
happening.  The CPU is not maxed out at these times and it should be 
able to easily do both with no dropouts. 
Comment 2 Martin Stransky 2005-01-28 06:36:48 EST
Could you check it in new rawhide?
Comment 3 Erich Hoover 2005-02-01 11:43:02 EST
No problems in the new rawhide, though I have no idea where the fix
would have occurred since there's been a lot of updates since the
original problem.

Note You need to log in before you can comment on or make changes to this bug.