Bug 134428 - 3c905 [Boomerang] does not work if kudzu is enabled
3c905 [Boomerang] does not work if kudzu is enabled
Status: CLOSED DUPLICATE of bug 119965
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-02 07:03 EDT by David Juran
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2004-10-02 07:03:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
If I enable kudzu (chkconfig kudzu on) and restart my computer, my
3Com 3c905 Boomerang NIC will not work. In syslog I see the following
messages:

Oct  2 12:46:36 localhost kernel: PCI: Found IRQ 10 for device
0000:00:0b.0
Oct  2 12:46:36 localhost kernel: 3c59x: Donald Becker and others.
www.scyld.com/network/vortex.html
Oct  2 12:46:36 localhost kernel: 0000:00:0b.0: 3Com PCI 3c905
Boomerang 100baseTx at 0xa800. Vers LK1.1.19
Oct  2 12:46:37 localhost kernel: eth0: Dropping NETIF_F_SG since no
checksum feature.
Oct  2 12:46:37 localhost kernel: ip_tables: (C) 2000-2002 Netfilter
core team
Oct  2 12:46:37 localhost kernel: PCI: Found IRQ 10 for device
0000:00:0b.0
Oct  2 12:46:37 localhost kernel: 3c59x: Donald Becker and others.
www.scyld.com/network/vortex.html
Oct  2 12:46:37 localhost kernel: 0000:00:0b.0: 3Com PCI 3c905
Boomerang 100baseTx at 0xa800. Vers LK1.1.19
Oct  2 12:46:37 localhost kernel: eth0: Dropping NETIF_F_SG since no
checksum feature.
Oct  2 12:46:37 localhost kernel: ip_tables: (C) 2000-2002 Netfilter
core team
Oct  2 12:46:37 localhost kernel: eth0: Host error, FIFO diagnostic
register 2000.
Oct  2 12:46:37 localhost kernel: eth0: PCI bus error, bus status 00a00021
Oct  2 12:46:37 localhost kernel: Badness in local_bh_enable at
kernel/softirq.c:141
Oct  2 12:46:37 localhost kernel:  [<021266b2>] local_bh_enable+0x39/0x5c
Oct  2 12:46:37 localhost kernel:  [<328e494d>] mdio_read+0x10e/0x12c
[3c59x]
Oct  2 12:46:37 localhost kernel:  [<328e1ff8>] vortex_up+0x298/0x668
[3c59x]
Oct  2 12:46:37 localhost kernel:  [<328e2de0>]
vortex_error+0x200/0x2bd [3c59x]
Oct  2 12:46:37 localhost kernel:  [<328e3942>]
boomerang_interrupt+0x2a3/0x3a4 [3c59x]
Oct  2 12:46:37 localhost kernel:  [<02129e35>] update_wall_time+0x9/0x31
Oct  2 12:46:37 localhost kernel:  [<0210bb02>] timer_interrupt+0xbe/0x17f
Oct  2 12:46:37 localhost kernel:  [<02107570>] handle_IRQ_event+0x21/0x41
Oct  2 12:46:37 localhost kernel:  [<02107974>] do_IRQ+0x159/0x225
Oct  2 12:46:38 localhost kernel:  =======================
Oct  2 12:46:38 localhost kernel:  [<02104018>] default_idle+0x0/0x2c
Oct  2 12:46:38 localhost kernel:  [<02104041>] default_idle+0x29/0x2c
Oct  2 12:46:38 localhost kernel:  [<0210409d>] cpu_idle+0x26/0x3b
Oct  2 12:46:38 localhost kernel:  [<023997a8>] start_kernel+0x1c4/0x1c9
Oct  2 12:46:38 localhost kernel: Badness in local_bh_enable at
kernel/softirq.c:141
Oct  2 12:46:38 localhost kernel:  [<021266b2>] local_bh_enable+0x39/0x5c
Oct  2 12:46:38 localhost kernel:  [<328e494d>] mdio_read+0x10e/0x12c
[3c59x]
Oct  2 12:46:38 localhost kernel:  [<328e200e>] vortex_up+0x2ae/0x668
[3c59x]
Oct  2 12:46:38 localhost kernel:  [<328e2de0>]
vortex_error+0x200/0x2bd [3c59x]
Oct  2 12:46:38 localhost kernel:  [<328e3942>]
boomerang_interrupt+0x2a3/0x3a4 [3c59x]
Oct  2 12:46:38 localhost kernel:  [<02129e35>] update_wall_time+0x9/0x31
Oct  2 12:46:38 localhost kernel:  [<0210bb02>] timer_interrupt+0xbe/0x17f
Oct  2 12:46:39 localhost kernel:  [<02107570>] handle_IRQ_event+0x21/0x41
Oct  2 12:46:39 localhost kernel:  [<02107974>] do_IRQ+0x159/0x225
Oct  2 12:46:39 localhost kernel:  =======================
Oct  2 12:46:39 localhost kernel:  [<02104018>] default_idle+0x0/0x2c
Oct  2 12:46:39 localhost kernel:  [<02104041>] default_idle+0x29/0x2c
Oct  2 12:46:39 localhost kernel:  [<0210409d>] cpu_idle+0x26/0x3b
Oct  2 12:46:39 localhost kernel:  [<023997a8>] start_kernel+0x1c4/0x1c9
Oct  2 12:46:39 localhost kernel: eth0: Transmit error, Tx status
register d0.
Oct  2 12:46:39 localhost kernel:   Flags; bus-master 1, dirty 1(1)
current 1(1)
Oct  2 12:46:39 localhost kernel:   Transmit list 00000000 vs. 3103b2a0.
Oct  2 12:46:39 localhost kernel:   0: @3103b200  length 80000156
status 80000156
Oct  2 12:46:39 localhost kernel:   1: @3103b2a0  length 00000000
status 00000000
Oct  2 12:46:40 localhost kernel:   2: @3103b340  length 00000000
status 00000000
Oct  2 12:46:40 localhost kernel:   3: @3103b3e0  length 00000000
status 00000000
Oct  2 12:46:40 localhost kernel:   4: @3103b480  length 00000000
status 00000000
Oct  2 12:46:40 localhost kernel:   5: @3103b520  length 00000000
status 00000000
Oct  2 12:46:40 localhost kernel:   6: @3103b5c0  length 00000000
status 00000000
Oct  2 12:46:40 localhost kernel:   7: @3103b660  length 00000000
status 00000000
Oct  2 12:46:40 localhost kernel:   8: @3103b700  length 00000000
status 00000000
Oct  2 12:46:40 localhost kernel:   9: @3103b7a0  length 00000000
status 00000000
Oct  2 12:46:40 localhost kernel:   10: @3103b840  length 00000000
status 00000000
Oct  2 12:46:40 localhost kernel:   11: @3103b8e0  length 00000000
status 00000000
Oct  2 12:46:40 localhost kernel:   12: @3103b980  length 00000000
status 00000000
Oct  2 12:46:41 localhost kernel:   13: @3103ba20  length 00000000
status 00000000
Oct  2 12:46:41 localhost kernel:   14: @3103bac0  length 00000000
status 00000000
Oct  2 12:46:41 localhost kernel:   15: @3103bb60  length 00000000
status 00000000

If I disable kudzu at startup everything works fine. 
I'm using kudzu-1.1.68.2-1

Version-Release number of selected component (if applicable):
kernel-smp-2.6.8-1.541

How reproducible:
Always

Steps to Reproduce:
1. chkconfig kudzu on
2. restart computer

    

Additional info:
Comment 1 David Juran 2004-10-02 07:36:09 EDT

*** This bug has been marked as a duplicate of 119965 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.