Bug 1344307 - Horizon help URL points to upstream documentation
Summary: Horizon help URL points to upstream documentation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 9.0 (Mitaka)
Hardware: x86_64
OS: All
unspecified
medium
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Gaël Chamoulaud
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-09 11:44 UTC by Ido Ovadia
Modified: 2016-08-16 04:30 UTC (History)
16 users (show)

Fixed In Version: openstack-tripleo-heat-templates-2.0.0-24.el7ost
Doc Type: Bug Fix
Doc Text:
This patch updates the Help URL on the dashboard. The URL now points to the Official Red Hat OpenStack Platform documentation instead of the OpenStack upstream documentation.
Clone Of:
Environment:
Last Closed: 2016-08-11 11:32:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC

Description Ido Ovadia 2016-06-09 11:44:35 UTC
Description of problem:
=======================
Horizon help URL points to http://docs.openstack.org/

Version-Release number of selected component:
=============================================
python-django-horizon-9.0.0-4.el7ost.noarch

How reproducible:
=================
100%

Steps to Reproduce:
===================
1. Deploy Undercloud and overcloud  
2. Login to Horizon dashboard 
3. Click help button on right corner 

Actual results:
===============
Help button redirect to 

http://docs.openstack.org/

Expected results:
=================

Help button should redirect to

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/.....

Comment 1 Matthias Runge 2016-06-13 08:30:55 UTC
it seems to be an installer bug.

While there is docs.openstack.org set up in openstack_dashboard/settings.py, but not in local_settings.py.example (which is the template file for /etc/openstack-dashboard/local_settings

I still find docs.openstack.org in /etc/openstack-dashboard/local_settings

Comment 11 Ido Ovadia 2016-08-02 11:33:55 UTC
Verified:
=========
openstack-tripleo-heat-templates-2.0.0-26.el7ost.noarch

Comment 13 errata-xmlrpc 2016-08-11 11:32:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.