Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1344310 - Migration of vanilla RHEL6-based 3.6 HE VM to appliance-based 4.0 HE VM failed
Summary: Migration of vanilla RHEL6-based 3.6 HE VM to appliance-based 4.0 HE VM failed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.0.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ovirt-4.0.0-rc
: 2.0.0.1
Assignee: Simone Tiraboschi
QA Contact: Jiri Belka
URL:
Whiteboard:
Depends On:
Blocks: 1319457
TreeView+ depends on / blocked
 
Reported: 2016-06-09 11:52 UTC by Jiri Belka
Modified: 2017-05-11 09:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-05 08:00:40 UTC
oVirt Team: Integration
rule-engine: ovirt-4.0.0+
ylavi: blocker+
rule-engine: planning_ack+
dfediuck: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 58985 0 master MERGED upgrade: fixing env configuration on upgrade 2016-06-10 15:00:50 UTC

Description Jiri Belka 2016-06-09 11:52:36 UTC
Description of problem:

According to stirabos@ migration of vanilla RHEL6-based (ie. normal installation, not appliance) 3.6 HE VM to appliance-based 4.0 HE VM should be supported.

Trying this action flow, the setup fails with following end output:

~~~
[ INFO  ] Trying to get a fresher copy of vm configuration from the OVF_STORE
[ ERROR ] Unable to get vm.conf from OVF_STORE, falling back to initial vm.conf
          Please install and setup the engine in the VM.
          You may also be interested in installing ovirt-guest-agent-common package in the VM.
         
         
          The VM has been rebooted.
          To continue please install oVirt-Engine in the VM
          (Follow http://www.ovirt.org/Quick_Start_Guide for more info).
         
          Make a selection from the options below:
          (1) Continue setup - oVirt-Engine installation is ready and ovirt-engine service is up
          (2) Abort setup
          (3) Power off and restart the VM
          (4) Destroy VM and abort setup
         
          (1, 2, 3, 4)[1]: 3 
[ INFO  ] Creating VM
[ ERROR ] Failed to execute stage 'Closing up': 'OVEHOSTED_VM/subst'
[ INFO  ] Stage: Clean up
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Hosted Engine upgrade failed: this system is not reliable, please check the issue, fix and try again
          Log file is located at /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160609120617-h4vd5v.log
~~~

Checking currently running HE VM via vnc console, I see it is stucked in boot because it cannot boot from disk.

Starting HE VM again causes HE VM run with old (original) disk and have 3.6 env.

I would expect following flow:

* setup attaches appliance as another disk to existing HE VM
* restarts HE VM and restores backup
* asks for confirmation that everything is OK
* HE VM is powered off
* when global maintenance is over, HE HA agents would start 


Version-Release number of selected component (if applicable):
ovirt-hosted-engine-ha-1.3.5.7-1.el7ev.noarch
ovirt-hosted-engine-ha-2.0.0-1.el7ev.noarch
ovirt-hosted-engine-setup-1.3.7.1-1.el7ev.noarch
ovirt-hosted-engine-setup-2.0.0-1.el7ev.noarch
rhevm-appliance-20160526.0-1.el7ev.noarch


How reproducible:
100%

Steps to Reproduce:
1. 3.6 HE VM environment - HE VM is (vanilla) RHEL6, not an appliance
2. add 4.0 repos and put the env into global maintenance
3. hosted-engine --upgrade-appliance

Actual results:
- during setup process, HE VM was rebooted and is stucked in booting
  (no bootable  device)
- when the VM is rebooted after the setup failure, it runs with old disk

Expected results:
during setup process HE VM runs with 4.0 appliance disk and guest OS is running

Additional info:

Comment 2 Red Hat Bugzilla Rules Engine 2016-06-10 08:08:50 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 3 Red Hat Bugzilla Rules Engine 2016-06-10 08:23:37 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 4 Jiri Belka 2016-06-22 14:01:04 UTC
ok, i could not reproduce with rhevm 3.6.7 env to rhevm 4.0.0-18. Although it did fail later because of BZ1343593 (resp. https://bugzilla.redhat.com/show_bug.cgi?id=1347731).

Comment 5 Sandro Bonazzola 2016-07-05 08:00:40 UTC
oVirt 4.0.0 has been released, closing current release.


Note You need to log in before you can comment on or make changes to this bug.