Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1344337 - If connection issues happened, fallback to XMLRPC protocol is much faster than expected
Summary: If connection issues happened, fallback to XMLRPC protocol is much faster tha...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.0.0-rc
: 4.0.0
Assignee: Martin Perina
QA Contact: movciari
URL:
Whiteboard:
Depends On:
Blocks: 1345779
TreeView+ depends on / blocked
 
Reported: 2016-06-09 12:37 UTC by Martin Perina
Modified: 2016-07-26 10:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1345779 (view as bug list)
Environment:
Last Closed: 2016-07-26 10:58:53 UTC
oVirt Team: Infra
rule-engine: ovirt-4.0.0+
rule-engine: planning_ack+
mperina: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 58911 0 master MERGED core: Fix fallback to XMLRPC during protocol detection 2016-06-10 09:16:37 UTC
oVirt gerrit 58965 0 ovirt-engine-4.0 MERGED core: Fix fallback to XMLRPC during protocol detection 2016-06-10 11:11:14 UTC

Description Martin Perina 2016-06-09 12:37:45 UTC
Description of problem:

If there is a connection issue during 1st connection to the host after installation, we switch to XMLRPC protocol immediately instead of trying number of times as defined in ProtocolFallbackRetries.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2016-06-09 12:38:43 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Martin Perina 2016-06-10 15:10:37 UTC
Setting target release to 4.0.0 as it's included in today's 4.0.0.4 build

Comment 4 Lukas Svaty 2016-07-26 10:58:53 UTC
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA


Note You need to log in before you can comment on or make changes to this bug.