Bug 134438 - anaconda limits detection to 16 raid devices
anaconda limits detection to 16 raid devices
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-02 14:14 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: anaconda-10.0.3.14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 07:48:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-10-02 14:14:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040929

Description of problem:
It used to work to have raid devices up to /dev/md31 (the old dev had
devices for them all).  Now the install image has md devices only up
to /dev/md15, breaking existing kickstart scripts and set ups.

Version-Release number of selected component (if applicable):
anaconda-10.0.3.9-1

How reproducible:
Always

Steps to Reproduce:
1.Create /dev/md16 or above
2.Set up an LVM member or a raid filesystem listed in the kickstart file
3.Attempt to install

Actual Results:  VT3 has error messages about missing device names and
bad magic numbers in other existing raid devices (that were not
brought up properly, presumably because of the above).  If using LVM
for any partitions specified in the kickstart file, VT3 gets a message
about vgscan having failed, and anaconda pops up a cryptic message
about the missing logical volume `None' in the named volume group.

Expected Results:  A similar kickstart file worked using devices up to
/dev/md19 in FC3test2, and it's not just because I added two more raid
devices in /dev/md20 and /dev/md21 for /boot devices that it fails.

Additional info:

Unfortunately, creating the raid devices in %pre is too late.  You
have to quickly drop to VT2 and run a bunch of mknods before anaconda
scans the devices to work around the problem.  It would be nice if the
kickstart file could have a section with commands to be run before
disk detection.  It's not the first time I run into a situation in
which it would be helpful.
Comment 1 Jeremy Katz 2004-10-04 09:28:13 EDT
Fixed in CVS.
Comment 2 Alexandre Oliva 2004-10-05 07:48:39 EDT
Confirmed fixed in FC3-re1004.2, thanks!

Note You need to log in before you can comment on or make changes to this bug.