Bug 1344380 - Run gnocchi-upgrade with '--create-legacy-resource-types' during deployment
Summary: Run gnocchi-upgrade with '--create-legacy-resource-types' during deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Pradeep Kilambi
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-09 14:16 UTC by Yurii Prokulevych
Modified: 2016-08-11 11:32 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-heat-templates-2.0.0-23.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 11:32:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC
OpenStack gerrit 337720 None None None 2016-07-07 19:34:36 UTC
Launchpad 1592449 None None None 2016-06-14 22:13:19 UTC

Description Yurii Prokulevych 2016-06-09 14:16:42 UTC
Description of problem:
By default, resources from /etc/ceilometer/gnocchi_resources.yaml ain't created in Gnocchi. This causes ceilometer dispatcher to fail while dispatching meters there. 

Excerpt from ceilometer/collector.log
...
2016-06-09 13:58:11.825 29725 DEBUG oslo_messaging._drivers.amqpdriver [-] received message msg_id: None reply to None __call__ /usr/lib/python2.7/site-packages/oslo_messaging/_drivers/amqpdriver.py:201
2016-06-09 13:58:13.888 29725 ERROR ceilometer.dispatcher.gnocchi [-] Resource type swift_account does not exist (HTTP 404)
...


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-gnocchi-common-2.1.1-1.el7ost.noarch
openstack-gnocchi-metricd-2.1.1-1.el7ost.noarch
openstack-gnocchi-indexer-sqlalchemy-2.1.1-1.el7ost.noarch
openstack-gnocchi-carbonara-2.1.1-1.el7ost.noarch
openstack-gnocchi-statsd-2.1.1-1.el7ost.noarch
python-gnocchiclient-2.2.0-1.el7ost.noarch
python-gnocchi-2.1.1-1.el7ost.noarch
openstack-gnocchi-api-2.1.1-1.el7ost.noarch

openstack-tripleo-heat-templates-2.0.0-9.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-9.el7ost.noarch
openstack-tripleo-image-elements-0.9.9-4.el7ost.noarch
python-tripleoclient-2.0.0-1.0.3.el7ost.noarch
openstack-tripleo-common-2.0.0-5.el7ost.noarch
openstack-tripleo-0.0.8-0.2.d81bd6dgit.el7ost.noarch
openstack-tripleo-puppet-elements-2.0.0-2.el7ost.noarch
openstack-tripleo-heat-templates-kilo-2.0.0-9.el7ost.noarch

Steps to Reproduce:
-------------------
1. Install overcloud
2. Switch ceilometer to use Gnocchi as a backend

Additional info:
----------------
Virtual setup: 3controller +2computes +2cephs

Comment 9 Yurii Prokulevych 2016-08-02 09:31:18 UTC
gnocchi  resource list-types
+----------------------------+--------------------------------------------------------------+
| resource_type              | resource_controller_url                                      |
+----------------------------+--------------------------------------------------------------+
| instance                   | http://192.0.2.6:8041/v1/resource/instance                   |
| ceph_account               | http://192.0.2.6:8041/v1/resource/ceph_account               |
| network                    | http://192.0.2.6:8041/v1/resource/network                    |
| host_network_interface     | http://192.0.2.6:8041/v1/resource/host_network_interface     |
| instance_network_interface | http://192.0.2.6:8041/v1/resource/instance_network_interface |
| ipmi                       | http://192.0.2.6:8041/v1/resource/ipmi                       |
| image                      | http://192.0.2.6:8041/v1/resource/image                      |
| host_disk                  | http://192.0.2.6:8041/v1/resource/host_disk                  |
| swift_account              | http://192.0.2.6:8041/v1/resource/swift_account              |
| volume                     | http://192.0.2.6:8041/v1/resource/volume                     |
| generic                    | http://192.0.2.6:8041/v1/resource/generic                    |
| host                       | http://192.0.2.6:8041/v1/resource/host                       |
| instance_disk              | http://192.0.2.6:8041/v1/resource/instance_disk              |
| stack                      | http://192.0.2.6:8041/v1/resource/stack                      |
| identity                   | http://192.0.2.6:8041/v1/resource/identity                   |
+----------------------------+--------------------------------------------------------------+

Packages:
---------
openstack-tripleo-heat-templates-2.0.0-24.el7ost.noarch
openstack-tripleo-heat-templates-kilo-0.8.14-16.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-24.el7ost.noarch
openstack-heat-templates-0-0.3.96a0b0bgit.el7ost.noarch

Comment 11 errata-xmlrpc 2016-08-11 11:32:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.