Bug 134439 - first up2date run after fresh install prints hideous debugging messages
first up2date run after fresh install prints hideous debugging messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-10-02 14:56 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-08 01:41:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-10-02 14:56:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040929

Description of problem:


Version-Release number of selected component (if applicable):
up2date-4.3.40-1

How reproducible:
Always

Steps to Reproduce:
1.Perform a fresh install
2.Run up2date -i somerandompackage

Actual Results:  The up2date configuration window pops up.  When it
closes, the terminal from which you started up2date has the following
piece of garbage:

[('isatty', 1), ('rhnuuid', '3768588c-1478-11d9-8e3c-00e07da94c98'),
('retrieveOnly', 0), ('debug', 0), ('useRhn', 0),
('showAvailablePackages', 0), ('useNoSSLForPackages', 0),
('storageDir', '/var/spool/up2date'), ('pkgSkipList', ['kernel*']),
('noSSLServerURL', 'http://xmlrpc.rhn.redhat.com/XMLRPC'),
('networkRetries', 5), ('pkgsToInstallNotUpdate', ['kernel',
'kernel-modules']), ('enableProxy', 0), ('noBootLoader', 0),
('proxyPassword', ''), ('updateUp2date', 1), ('keepAfterInstall', 0),
('useGPG', 1), ('headerCacheSize', 40), ('forceInstall', 0),
('systemIdPath', '/etc/sysconfig/rhn/systemid'), ('retrieveSource',
0), ('enableRollbacks', 0), ('gpgKeyRing',
'/etc/sysconfig/rhn/up2date-keyring.gpg'), ('adminAddress',
['root@localhost']), ('serverURL',
'https://xmlrpc.rhn.redhat.com/XMLRPC'), ('fileSkipList', []),
('versionOverride', ''), ('sslCACert', '/usr/share/rhn/RHNS-CA-CERT'),
('noReplaceConfig', 1), ('enableProxyAuth', 0),
('disallowConfChanges', ['noReboot', 'sslCACert',
'useNoSSLForPackages', 'noSSLServerURL', 'serverURL',
'disallowConfChanges']), ('headerFetchCount', 10), ('proxyUser', ''),
('removeSkipList', ['kernel*']), ('httpProxy', ''), ('noReboot', 0)]
GHHHHHHHHHHHHHHHHHHHHHHHHHH 0 False
fffffffffffff
/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py:90:
GtkDeprecationWarning: gtk.mainloop is deprecated, use gtk.main instead
  self.warn(message, DeprecationWarning)
/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py:90:
GtkDeprecationWarning: gtk.mainquit is deprecated, use gtk.main_quit
instead
  self.warn(message, DeprecationWarning)
why am I calling mainquit?


Expected Results:  No such junk.

Additional info:
Comment 1 Alexandre Oliva 2004-10-22 19:50:42 EDT
These messages are still present in up2date-4.3.46-1.  Most people
probably won't see it because the first invocation of up2date is from
firstboot, but if you do a kickstart install, firstboot doesn't run,
and then you get to see these ugly messages when you first run
up2date.  Please oh please remove this before FC3 final.
Comment 2 Adrian Likins 2004-11-01 16:25:17 EST
should be fixed in next build 4.3.51

Note You need to log in before you can comment on or make changes to this bug.