Bug 1344407 - fail delete volume operation if one of the glusterd instance is down in cluster
Summary: fail delete volume operation if one of the glusterd instance is down in cluster
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1344625 1344631 1344634
TreeView+ depends on / blocked
 
Reported: 2016-06-09 15:25 UTC by Atin Mukherjee
Modified: 2017-03-27 18:12 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1344625 1344631 1344634 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:12:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2016-06-09 15:25:42 UTC
Description of problem:

If a volume is deleted when one of the glusterd instance on a node is down in the cluster then once glusterd comes back it re-syncs the same volume to all of the nodes. User will get annoyed to see the volume back into the namespace.

Version-Release number of selected component (if applicable):
mainline

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-06-09 15:38:08 UTC
REVIEW: http://review.gluster.org/14681 (glusterd: fail volume delete if one of the node is down) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Vijay Bellur 2016-06-10 07:31:02 UTC
COMMIT: http://review.gluster.org/14681 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 5016cc548d4368b1c180459d6fa8ae012bb21d6e
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Jun 9 18:22:43 2016 +0530

    glusterd: fail volume delete if one of the node is down
    
    Deleting a volume on a cluster where one of the node in the cluster is down is
    buggy since once that node comes back the resync of the same volume will happen.
    Till we bring in the soft delete feature tracked in
    http://review.gluster.org/12963 this is a safe guard to block the volume
    deletion.
    
    Change-Id: I9c13869c4a7e7a947f88842c6dc6f231c0eeda6c
    BUG: 1344407
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/14681
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 3 Vijay Bellur 2016-06-10 08:56:32 UTC
REVIEW: http://review.gluster.org/14693 (tests: fix bug-1344407-volume-delete-on-node-down.t) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Vijay Bellur 2016-06-13 06:54:20 UTC
COMMIT: http://review.gluster.org/14693 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 53cc21c5a5df434039f587644c336bf4f7264f45
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Fri Jun 10 14:25:14 2016 +0530

    tests: fix bug-1344407-volume-delete-on-node-down.t
    
    Test was earlier starting the volume which will always make volume delete fail.
    so it was actually not validating BZ 1344407
    
    Change-Id: I6761be16e414bb7b67694ff1a468073bfdd872ac
    BUG: 1344407
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/14693
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 5 Shyamsundar 2017-03-27 18:12:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.