Bug 1344472 - no focus for panel elements if using crtl-alt-tab
Summary: no focus for panel elements if using crtl-alt-tab
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-panel
Version: 24
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F24FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2016-06-09 18:48 UTC by Wolfgang Ulbrich
Modified: 2016-06-16 00:03 UTC (History)
3 users (show)

Fixed In Version: mate-panel-1.14.1-1.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 00:03:09 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Wolfgang Ulbrich 2016-06-09 18:48:10 UTC
Description of problem:

mate-panel-1.14.0 have an focus issue which make it impossiple to select the panels with crtl-alt-tab for peopple with visual disturbances.
Using orca does not work, means as the panel is is a main element of Mate desktop, the whole the desktop can't be used.

If someone installed f24 mate spin and have to use orca it is impossible to update to the fixed version.

This is fixed with new upstream release 1.14.1


Version-Release number of selected component (if applicable):

1.14.0

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Wolfgang Ulbrich 2016-06-09 18:49:49 UTC
more details you'll find at this upstream report.
https://github.com/mate-desktop/mate-panel/issues/441

Comment 2 Fedora Update System 2016-06-09 19:17:32 UTC
mate-panel-1.14.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-eebf6845cf

Comment 3 Fedora Blocker Bugs Application 2016-06-09 19:23:34 UTC
Proposed as a Freeze Exception for 24-final by Fedora user raveit65 using the blocker tracking app because:

 mate-panel-1.14.0 have an focus issue which make it impossiple to select the panels with crtl-alt-tab for peopple with visual disturbances.
Using orca does not work, means as the panel is is a main element of Mate desktop, the whole the desktop can't be used.

If someone installed f24 mate spin and have to use orca it is impossible to update to the fixed version.

This is fixed with new upstream release 1.14.1

Comment 4 Fedora Update System 2016-06-10 18:00:40 UTC
mate-panel-1.14.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-eebf6845cf

Comment 5 Petr Schindler 2016-06-13 17:36:29 UTC
Discussed at 2016-06-13 blocker review meeting: [1]. 

This bug was accepted as Final Freeze Exception: this is clearly a significant issue that cannot be fixed with a post-release update, it is in a non-blocking desktop so cannot endanger the release

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-06-13/f24-blocker-review.2016-06-13-16.04.html

Comment 6 Fedora Update System 2016-06-16 00:03:07 UTC
mate-panel-1.14.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.