This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 134449 - /.autofsck causes switch to vt1 without ever switching back
/.autofsck causes switch to vt1 without ever switching back
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-02 17:02 EDT by Alexandre Oliva
Modified: 2014-03-16 22:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-17 00:52:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-10-02 17:02:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040929

Description of problem:
Since current rhgb displays fsck progress in the rhgb window, it is
now safe to switch back to rhgb after the prompt is answered or times
out.  Ideally, the prompt should be displayed in rhgb itself.

Version-Release number of selected component (if applicable):
rhgb-0.13.5-1
initscripts-7.85-1

How reproducible:
Always

Steps to Reproduce:
1.Reboot uncleanly


Actual Results:  rhgb go away for the `force file system check' prompt
and never come back

Expected Results:  rc.sysinit should switch back to vt8 before
starting the actual fsck, or not switch to vt1 if we could prompt
through rhgb

Additional info:
Comment 1 Alexandre Oliva 2004-10-02 17:04:53 EDT
DV says we probably can't feed initscripts any input, so it's tricky
to move the prompt into rhgb.  My suggestion is to intercept the
prompt, open a dialogue in rhgb, and store the result in a file in
/etc/rhgb that rc.sysinit would look for.
Comment 2 Bill Nottingham 2004-10-17 00:52:18 EDT
Fixed in 7.91-1, in that it switches back to rhgb after the fsck
finishes. More complicated fixes later. :)

Note You need to log in before you can comment on or make changes to this bug.