Bug 134456 - mDNSResponder starts in wrong SELinux domain
mDNSResponder starts in wrong SELinux domain
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: howl (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-02 18:29 EDT by Tom London
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 04:40:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2004-10-02 18:29:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041002
Firefox/0.10.1

Description of problem:
mDNSResponder is starting in the incorrect SELinux context (user_t).

The problem is the use of
     su -s /bin/bash - nobody -c mDNSResponder $OTHER_MDNSRD_OPTS >
/dev/null

to start /usr/bin/mDNSResponder.

It should be replaced with
   runuser -s /bin/bash - nobody -c mDNSResponder $OTHER_MDNSRD_OPTS >
/dev/null



Version-Release number of selected component (if applicable):
howl-0.9.6-5

How reproducible:
Always

Steps to Reproduce:
1. boot system with SELinux/strict/enforcing
2. 'ps agxZ' | grep mDNS
3.
    

Expected Results:  mDNSResponder should be executing in howl_t

Additional info:
Comment 1 Alexander Larsson 2004-10-04 04:40:09 EDT
Fixed in 2.9.6-6.

Note You need to log in before you can comment on or make changes to this bug.