Bug 1344636 - offset tests fail on big endians
Summary: offset tests fail on big endians
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: e2fsprogs
Version: rawhide
Hardware: s390x
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eric Sandeen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ZedoraTracker PPCTracker
TreeView+ depends on / blocked
 
Reported: 2016-06-10 08:40 UTC by Dan Horák
Modified: 2016-06-17 08:28 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-06-16 23:02:48 UTC


Attachments (Terms of Use)
u_mke2fs_opt_offset.failed (341 bytes, text/plain)
2016-06-10 08:44 UTC, Dan Horák
no flags Details
u_mke2fs_opt_offset.log (2.64 KB, text/plain)
2016-06-10 08:44 UTC, Dan Horák
no flags Details
u_offset.failed (398 bytes, text/plain)
2016-06-10 08:45 UTC, Dan Horák
no flags Details
u_offset.log (2.75 KB, text/plain)
2016-06-10 08:45 UTC, Dan Horák
no flags Details

Description Dan Horák 2016-06-10 08:40:49 UTC
When building latest e2fsprogs on big endian platforms (ppc64, s390x) 2 tests are failing

...
u_mke2fs_opt_offset: e2undo and mke2fs with offset option: failed
u_offset: e2undo with the offset option (-o offset): failed
...

for full logs please see eg. http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2255925


Version-Release number of selected component (if applicable):
e2fsprogs-1.43.1-1.fc25

Comment 1 Dan Horák 2016-06-10 08:44 UTC
Created attachment 1166559 [details]
u_mke2fs_opt_offset.failed

Comment 2 Dan Horák 2016-06-10 08:44 UTC
Created attachment 1166566 [details]
u_mke2fs_opt_offset.log

Comment 3 Dan Horák 2016-06-10 08:45 UTC
Created attachment 1166585 [details]
u_offset.failed

Comment 4 Dan Horák 2016-06-10 08:45 UTC
Created attachment 1166587 [details]
u_offset.log

Comment 5 Eric Sandeen 2016-06-10 14:29:16 UTC
It's quite possible that these are not regressions; they are new tests:

# git show cc090a3634b6a43979c7242a80c4d457b7a08ae2 | lsdiff
b/tests/u_mke2fs_opt_offset/script
b/tests/u_offset/script
# git describe --contains cc090a3634b6a43979c7242a80c4d457b7a08ae2
v1.43~9

Comment 6 Eric Sandeen 2016-06-13 16:52:11 UTC
I haven't yet found the root cause; I thought I found an endian conversion problem in the utility, but it did not resolve this issue.

Comment 7 Eric Sandeen 2016-06-16 23:02:48 UTC
Should be fixed in rawhide now.

Comment 8 Dan Horák 2016-06-17 08:28:46 UTC
Thanks, successfully built in s390 and ppc kojis.


Note You need to log in before you can comment on or make changes to this bug.