Bug 13447 - Several problems with upgrade from 6.1 to 6.2
Several problems with upgrade from 6.1 to 6.2
Status: CLOSED DUPLICATE of bug 13786
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
6.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-04 01:54 EDT by hugues.talbot
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-13 15:13:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description hugues.talbot 2000-07-04 01:54:36 EDT
Dear Sirs,

The 6.2 upgrade procedure has some terribly annoying features:

1- if a /etc/auto.master is NOT present before  the upgrade it
puts one there. In our case the auto.master information comes from 
an NIS map. The upgrade should not invent files when not needed.

2- The upgrade procedure changed the layout of /etc/rc.d/rc?.d/ 
files without notice. In particular it created a K20nfs in lieu
of a pre-existing S60nfs in rc3.d and  rc5.d. It also removed
a S95sshd there. 

3- Gdm reacts badly to unknown situations. It tries to restart
several times when some data is missing before settling down. 
A couple of times should be enough. The end results is that the
monitor tries to sync to a high frequency for the X stuff, then
something goes wrong (no way to tell what), then it syncs down to
text mode for a few milliseconds, and then tries again a number of
times. During that time the computer is unusable and looks about
to blow up. Fortunately GDM gives up after a while. Why not immediately? 
presently this is a surefire way to destroy monitors.

These are minor points but it made the difference between a smooth
15 minutes procedure and an annoying 2 hours one when trying to find
out what is happening.
Comment 1 Bill Nottingham 2000-07-04 15:34:30 EDT
The NFS thing was an intentional change in that it not be started by
default, although settings shouldn't be changed on upgrade; most likely
this is because the script moved packages, and it can't really be helped.

The auto.master confusion should be fixed in the latest autofs in rawhide.

Assigning the rest of the bug to gdm.
Comment 2 Havoc Pennington 2000-07-13 15:13:05 EDT

*** This bug has been marked as a duplicate of 13786 ***
Comment 3 Glen Foster 2000-07-18 09:22:08 EDT
This defect is closed (since it's a duplicate)

Note You need to log in before you can comment on or make changes to this bug.