Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1344758 - [GSS] Removal of bricks in volume isn't prevented if remaining brick doesn't contain all the files
Summary: [GSS] Removal of bricks in volume isn't prevented if remaining brick doesn't ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: rhgs-3.1
Hardware: x86_64
OS: Linux
high
low
Target Milestone: ---
: RHGS 3.5.z Batch Update 1
Assignee: Sanju
QA Contact: Sayalee
URL:
Whiteboard: dht-gss, dht-gss-ask, dht-3.2.0-proposed
Depends On: 1514683
Blocks: 1369781 1408949 RHGS-usability-bug-GSS RHGS-3.4-GSS-proposed-tracker 1481177
TreeView+ depends on / blocked
 
Reported: 2016-06-10 16:12 UTC by Cal Calhoun
Modified: 2021-03-11 14:35 UTC (History)
14 users (show)

Fixed In Version: glusterfs-6.0-23
Doc Type: Enhancement
Doc Text:
With this update removal of bricks will be aborted with a proper warning message if re-balance process has failed or there are some skipped files. However, users can still remove the brick by using 'force' option.
Clone Of:
: 1514683 (view as bug list)
Environment:
Last Closed: 2020-01-30 06:42:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0288 0 None None None 2020-01-30 06:43:02 UTC

Description Cal Calhoun 2016-06-10 16:12:31 UTC
Description of problem:

Customer wanted to test migration of data by adding and removing bricks to simulate moving between different storage.

1. Created a replicated volume made up of 2 x 279GB bricks.

2. Mounted as a gluster mount and then filed up untill approximately 500MB full.

3. Added additional bricks that were smaller, only 244MB.

4. Started removal of one 279GB brick which completed successfully.

5. Checked and there were still files left on the bricks being removed that couldn't be copied as the remaining brick wasn't large enough.

Removed brick without error, just a warning that files might be left behind.


Version-Release number of selected component (if applicable):

Gluster 3.7.5 (RHGS 3.1.2)


How reproducible:

Easily


Steps to Reproduce:

See above

Actual results:

Brick removal completed without error even though all files were not migrated.


Expected results:
Removal should fail or give more warning/require explicit approval before proceeding.

Additional info:

Comment 2 Atin Mukherjee 2016-06-10 16:23:00 UTC
remove brick commit functionality does have some cases where there could be data losses and that's why the CLI output throws up an warning message. I am moving this bug to zteam (DHT) for further comments.

Comment 8 Worker Ant 2017-11-18 02:12:39 UTC
REVISION POSTED: https://review.gluster.org/18801 (cli: WIP) posted (#2) for review on master by N Balachandran

Comment 25 Anjana KD 2020-01-29 17:19:48 UTC
have updated the doc text kindly verify the doc text- field.

Comment 27 errata-xmlrpc 2020-01-30 06:42:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0288


Note You need to log in before you can comment on or make changes to this bug.