Bug 134479 - apel (apel-xemacs) shouldn't require emacs (xemacs)
apel (apel-xemacs) shouldn't require emacs (xemacs)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: apel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-03 13:56 EDT by Lars Hupfeldt Nielsen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 10.6-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-06 06:42:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Hupfeldt Nielsen 2004-10-03 13:56:20 EDT
xemacs-nox needs xemacs-sumo needs apel-xemacs needs xemacs needs...

Steps to Reproduce:
List xemacs-nox in kickstart file.

Actual results:
Evan if skipx is specified a lot of X packages are installed
Comment 1 Jens Petersen 2004-10-06 06:19:03 EDT
This needs to be fixed in apel: I guess it doesn't need to
require xemacs since it is a library - alternatively it
could require xemacs-common instead.
Comment 2 Akira TAGOH 2004-10-06 06:21:37 EDT
ok, will do so then.
Comment 3 Jens Petersen 2004-10-06 06:27:50 EDT
Oh, I just realised the same is true for emacs I think:
Either the requires emacs can be dropped or instead
please require emacs-common.

I don't really know if any requirement is strictly necessary...
though it probably isn't a big deal since noone would normally
want to install apel without the -common packages I guess. :)
Comment 4 Akira TAGOH 2004-10-06 06:42:18 EDT
should be fixed in 10.6-5
Comment 5 Jens Petersen 2004-10-06 09:42:45 EDT
Fixing corresponding problems for flim, ddskk, emacspeak, emacs-el
and xemacs-el
Comment 6 Jens Petersen 2004-10-06 10:08:17 EDT
and psgml ;)

Note You need to log in before you can comment on or make changes to this bug.