Bug 134479 - apel (apel-xemacs) shouldn't require emacs (xemacs)
Summary: apel (apel-xemacs) shouldn't require emacs (xemacs)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: apel
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-03 17:56 UTC by Lars Hupfeldt Nielsen
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-10-06 10:42:18 UTC


Attachments (Terms of Use)

Description Lars Hupfeldt Nielsen 2004-10-03 17:56:20 UTC
xemacs-nox needs xemacs-sumo needs apel-xemacs needs xemacs needs...

Steps to Reproduce:
List xemacs-nox in kickstart file.

Actual results:
Evan if skipx is specified a lot of X packages are installed

Comment 1 Jens Petersen 2004-10-06 10:19:03 UTC
This needs to be fixed in apel: I guess it doesn't need to
require xemacs since it is a library - alternatively it
could require xemacs-common instead.

Comment 2 Akira TAGOH 2004-10-06 10:21:37 UTC
ok, will do so then.

Comment 3 Jens Petersen 2004-10-06 10:27:50 UTC
Oh, I just realised the same is true for emacs I think:
Either the requires emacs can be dropped or instead
please require emacs-common.

I don't really know if any requirement is strictly necessary...
though it probably isn't a big deal since noone would normally
want to install apel without the -common packages I guess. :)

Comment 4 Akira TAGOH 2004-10-06 10:42:18 UTC
should be fixed in 10.6-5

Comment 5 Jens Petersen 2004-10-06 13:42:45 UTC
Fixing corresponding problems for flim, ddskk, emacspeak, emacs-el
and xemacs-el

Comment 6 Jens Petersen 2004-10-06 14:08:17 UTC
and psgml ;)


Note You need to log in before you can comment on or make changes to this bug.