Bug 134484 - ISA Sound card detection hit and miss
ISA Sound card detection hit and miss
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ALSA
  Show dependency treegraph
 
Reported: 2004-10-03 20:43 EDT by Need Real Name
Modified: 2015-01-04 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 01:41:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-10-03 20:43:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
ISA sound card (cs4237) is sometimes iniailised and sometimes not

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
n/a

Actual Results:  Sometimes sound card is recognized and sometimes not
- no apparent consistency

output of cat /var/log/messages|grep snd
Oct  1 19:35:25 localhost kernel: Modules linked in: ppp_deflate
zlib_deflate ppp_async crc_ccitt ppp_generic slhc md5 ipv6 parport_pc
lp parport autofs4 sunrpc ns558 gameport snd_cs4236 snd_opl3_lib
snd_hwdep snd_cs4236_lib snd_mpu401_uart snd_rawmidi snd_seq_device
snd_cs4231_lib snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd
soundcore snd_page_alloc floppy ext3 jbd dm_mod
Oct  1 19:42:07 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  1 19:42:32 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  1 19:44:00 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  1 21:55:51 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 04:01:01 localhost kernel: Modules linked in: ppp_deflate
zlib_deflate ppp_async crc_ccitt ppp_generic slhc parport_pc lp
parport autofs4 sunrpc md5 ipv6 snd_opl3_lib snd_hwdep snd_cs4236_lib
snd_mpu401_uart snd_rawmidi snd_seq_device snd_cs4231_lib snd_pcm_oss
snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc floppy
ext3 jbd dm_mod
Oct  2 16:12:25 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 16:12:50 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 16:53:17 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 16:53:21 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 16:53:21 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 16:53:21 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 16:55:35 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 16:56:02 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 17:03:37 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 17:03:37 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 17:03:41 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 17:03:41 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 17:04:07 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 17:05:15 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 17:06:42 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 17:06:42 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 17:06:46 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 17:06:46 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 17:07:21 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 17:12:55 localhost kernel: Modules linked in: parport_pc lp
parport autofs4 md5 ipv6 snd_opl3_lib snd_hwdep snd_cs4236_lib
snd_mpu401_uart snd_rawmidi snd_seq_device snd_cs4231_lib snd_pcm_oss
snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc floppy
ext3 jbd dm_mod
Oct  2 17:21:25 localhost modprobe: FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.8-1.541/kernel/sound/isa/cs423x/snd-cs4236.ko): No
such device
Oct  2 18:18:53 localhost kernel: Modules linked in: nls_utf8
parport_pc lp parport autofs4 md5 ipv6 snd_opl3_lib snd_hwdep
snd_cs4236_lib snd_mpu401_uart snd_rawmidi snd_seq_device
snd_cs4231_lib snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd
soundcore snd_page_alloc floppy ext3 jbd dm_mod
Oct  2 21:18:27 localhost kernel: Modules linked in: nls_utf8
parport_pc lp parport autofs4 md5 ipv6 snd_opl3_lib snd_hwdep
snd_cs4236_lib snd_mpu401_uart snd_rawmidi snd_seq_device
snd_cs4231_lib snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd
soundcore snd_page_alloc floppy ext3 jbd dm_mod



Additional info:
Comment 1 Bill Nottingham 2004-10-03 23:45:08 EDT
Looks like either a driver bug or an invalid config.
Comment 2 Dave Jones 2005-07-15 14:37:35 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.