Bug 1344842 - [abrt] policycoreutils-gui: semanagePage.py:126:deleteDialog:TypeError: iter must be a GtkTreeIter
Summary: [abrt] policycoreutils-gui: semanagePage.py:126:deleteDialog:TypeError: iter ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: 23
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Lautrbach
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:ced01ceefc9c9bdc87c3547e3c8...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-11 16:07 UTC by Айфф
Modified: 2016-12-03 10:57 UTC (History)
4 users (show)

Fixed In Version: policycoreutils-2.5-15.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-03 10:57:02 UTC


Attachments (Terms of Use)
File: backtrace (734 bytes, text/plain)
2016-06-11 16:07 UTC, Айфф
no flags Details
File: environ (194 bytes, text/plain)
2016-06-11 16:07 UTC, Айфф
no flags Details

Description Айфф 2016-06-11 16:07:23 UTC
Version-Release number of selected component:
policycoreutils-gui-2.4-21.fc23

Additional info:
reporter:       libreport-2.6.4
cmdline:        /usr/bin/python -Es /usr/share/system-config-selinux/system-config-selinux.py
executable:     /usr/share/system-config-selinux/system-config-selinux.py
kernel:         4.5.6-200.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
semanagePage.py:126:deleteDialog:TypeError: iter must be a GtkTreeIter

Traceback (most recent call last):
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 128, in delete
    self.tabs[self.notebook.get_current_page()].deleteDialog()
  File "/usr/share/system-config-selinux/semanagePage.py", line 126, in deleteDialog
    if self.verify(_("Are you sure you want to delete %s '%s'?" % (self.description, store.get_value(it, 0))), _("Delete %s" % self.description)) == gtk.RESPONSE_YES:
TypeError: iter must be a GtkTreeIter

Local variables in innermost frame:
self: <modulesPage.modulesPage instance at 0x7f4ea0a2b488>
it: None
store: <gtk.ListStore object at 0x7f4e9a909dc0 (GtkListStore at 0x564b28289320)>

Potential duplicate: bug 805663

Comment 1 Айфф 2016-06-11 16:07:28 UTC
Created attachment 1166899 [details]
File: backtrace

Comment 2 Айфф 2016-06-11 16:07:29 UTC
Created attachment 1166900 [details]
File: environ

Comment 4 Petr Lautrbach 2016-11-21 15:21:53 UTC
https://github.com/fedora-selinux/selinux/pull/28

Comment 5 Petr Lautrbach 2016-11-21 15:22:33 UTC
https://github.com/fedora-selinux/selinux/pull/29

Comment 6 Fedora Update System 2016-11-22 16:53:13 UTC
libselinux-2.5-13.fc25 policycoreutils-2.5-18.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-17b60ec8d1

Comment 7 Fedora Update System 2016-11-22 22:53:36 UTC
secilc-2.5-6.fc24 checkpolicy-2.5-8.fc24 policycoreutils-2.5-15.fc24 libsemanage-2.5-6.fc24 libselinux-2.5-12.fc24 libsepol-2.5-10.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e780970d04

Comment 8 Fedora Update System 2016-11-23 23:07:41 UTC
libselinux-2.5-13.fc25, policycoreutils-2.5-18.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-17b60ec8d1

Comment 9 Fedora End Of Life 2016-11-25 09:16:43 UTC
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 10 Fedora Update System 2016-11-25 09:38:43 UTC
checkpolicy-2.5-8.fc24, libselinux-2.5-12.fc24, libsemanage-2.5-6.fc24, libsepol-2.5-10.fc24, policycoreutils-2.5-15.fc24, secilc-2.5-6.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e780970d04

Comment 11 Fedora Update System 2016-11-30 05:28:48 UTC
libselinux-2.5-13.fc25, policycoreutils-2.5-18.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-12-03 10:57:02 UTC
checkpolicy-2.5-8.fc24, libselinux-2.5-12.fc24, libsemanage-2.5-6.fc24, libsepol-2.5-10.fc24, policycoreutils-2.5-15.fc24, secilc-2.5-6.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.