Bug 1344846 - RFE: Option --disableexcludes could take no arg
Summary: RFE: Option --disableexcludes could take no arg
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 24
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1356914 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-11 16:46 UTC by srakitnican
Modified: 2017-03-31 16:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-31 16:10:07 UTC
Type: Bug


Attachments (Terms of Use)

Description srakitnican 2016-06-11 16:46:40 UTC
Description of problem: 

# dnf --disableexcludes list available
No such command: available. Please use /bin/dnf --help
It could be a DNF plugin command, try: "dnf install 'dnf-command(available)'"

Where something like following works fine:
# dnf --disableexcludes=all list available

According to docs operands are optional if I am not mistaken. "--disableexcludes=[all|main|<repoid>]". Square brackets indicate optional?


Version-Release number of selected component (if applicable):
dnf-1.1.9-2.fc24.noarch

How reproducible: Always


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fedora Admin XMLRPC Client 2016-07-08 09:30:39 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Igor Gnatenko 2016-07-21 15:10:13 UTC
*** Bug 1356914 has been marked as a duplicate of this bug. ***

Comment 3 Jaroslav Mracek 2016-12-20 16:21:11 UTC
I think that it is not good idea. If we will set the optional argument for --disableexcludes we will have a problem to distinguish if next argument belongs to that option or it is command. The repo id could shadow 'dnf commands' and I think it will be not wise to allow non-deterministic behavior for arg parser. I recommend to close it as wont fix.

Comment 4 Igor Gnatenko 2017-03-31 16:04:19 UTC
Yeah, in order to not have non-deterministic argparser I agree to close this as wontfix.


Note You need to log in before you can comment on or make changes to this bug.