Bug 1344863 - AttributeError: 'Iso9660FS' object has no attribute 'partitions'
Summary: AttributeError: 'Iso9660FS' object has no attribute 'partitions'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker abrt_hash:3e78abebafd...
: 1344856 1368835 1375505 (view as bug list)
Depends On:
Blocks: F24FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-06-11 20:10 UTC by jhawk
Modified: 2016-09-13 09:27 UTC (History)
10 users (show)

Fixed In Version: anaconda-24.13.7-1 anaconda-24.13.7-1.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 00:02:33 UTC


Attachments (Terms of Use)
File: anaconda-tb (1.39 MB, text/plain)
2016-06-11 20:11 UTC, jhawk
no flags Details
File: anaconda.log (42.79 KB, text/plain)
2016-06-11 20:11 UTC, jhawk
no flags Details
File: environ (589 bytes, text/plain)
2016-06-11 20:11 UTC, jhawk
no flags Details
File: journalctl (597.76 KB, text/plain)
2016-06-11 20:11 UTC, jhawk
no flags Details
File: lsblk_output (2.35 KB, text/plain)
2016-06-11 20:12 UTC, jhawk
no flags Details
File: nmcli_dev_list (1.59 KB, text/plain)
2016-06-11 20:12 UTC, jhawk
no flags Details
File: os_info (449 bytes, text/plain)
2016-06-11 20:12 UTC, jhawk
no flags Details
File: program.log (156.77 KB, text/plain)
2016-06-11 20:12 UTC, jhawk
no flags Details
File: storage.log (588.10 KB, text/plain)
2016-06-11 20:12 UTC, jhawk
no flags Details
File: ifcfg.log (4.61 KB, text/plain)
2016-06-11 20:12 UTC, jhawk
no flags Details

Description jhawk 2016-06-11 20:10:56 UTC
Description of problem:
Attempting to install F24-RC 1.1 MATE-Compiz spin.

- Selected Automatic Partioning.
- Prompted to Reclaim Space and I accepted.
- I selected "Delete" on my HDD to reclaim all space from existing F24 Beta installation.
- Clicked Done and was brought back to Installation Summary page. 
- Installation Destination attempted to save my parition selection and once it completed saving I was prompted with this error message.

Version-Release number of selected component:
anaconda-core-24.13.6-1.fc24.x86_64

The following was filed automatically by anaconda:
anaconda 24.13.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/storage_utils.py", line 360, in check_mounted_partitions
    for part in disk.format.partitions:
  File "/usr/lib64/python3.5/site-packages/pyanaconda/storage_utils.py", line 326, in sanity_check
    exns += check_mounted_partitions(storage)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/kickstart.py", line 342, in execute
    errors = sanity_check(storage)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/kickstart.py", line 2220, in doKickstartStorage
    ksdata.autopart.execute(storage, ksdata, instClass)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 381, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python3.5/threading.py", line 862, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'Iso9660FS' object has no attribute 'partitions'

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz root=live:CDLABEL=Fedora-MATE-Live-24-1-1 rd.live.image quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.5.5-300.fc24.x86_64
other involved packages: anaconda-gui-24.13.6-1.fc24.x86_64, system-python-libs-3.5.1-7.fc24.x86_64
product:        Fedora
release:        Fedora release 24 (Twenty Four)
reproducible:   Not sure how to reproduce the problem
type:           anaconda
version:        24

Comment 1 jhawk 2016-06-11 20:11:30 UTC
Created attachment 1167023 [details]
File: anaconda-tb

Comment 2 jhawk 2016-06-11 20:11:37 UTC
Created attachment 1167024 [details]
File: anaconda.log

Comment 3 jhawk 2016-06-11 20:11:39 UTC
Created attachment 1167025 [details]
File: environ

Comment 4 jhawk 2016-06-11 20:11:57 UTC
Created attachment 1167026 [details]
File: journalctl

Comment 5 jhawk 2016-06-11 20:12:00 UTC
Created attachment 1167027 [details]
File: lsblk_output

Comment 6 jhawk 2016-06-11 20:12:04 UTC
Created attachment 1167028 [details]
File: nmcli_dev_list

Comment 7 jhawk 2016-06-11 20:12:07 UTC
Created attachment 1167029 [details]
File: os_info

Comment 8 jhawk 2016-06-11 20:12:13 UTC
Created attachment 1167030 [details]
File: program.log

Comment 9 jhawk 2016-06-11 20:12:28 UTC
Created attachment 1167031 [details]
File: storage.log

Comment 10 jhawk 2016-06-11 20:12:31 UTC
Created attachment 1167032 [details]
File: ifcfg.log

Comment 11 David Shea 2016-06-13 13:28:05 UTC
*** Bug 1344856 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Blocker Bugs Application 2016-06-13 14:52:18 UTC
Proposed as a Blocker for 24-final by Fedora user dshea using the blocker tracking app because:

 It is not possible to complete an install when booting from the installer media as a USB device.

Comment 13 David Shea 2016-06-13 14:53:45 UTC
This affects all spins, live and otherwise. I believe it was introduced by 6fd37a3e8f839890762b165c5a69f38bafd5a4eb for bug 1330820: the check trips on disks that have no partitions, such as a disk with an iso9660 image written to it.

Comment 14 Adam Williamson 2016-06-13 16:27:03 UTC
confirmed I see this with the RC-1.1 Workstation live dd'ed to USB, even though the USB stick is not selected as an install target. The crash occurs on return to main hub from target disk selection.

Comment 15 Adam Williamson 2016-06-13 17:24:31 UTC
I guess the fix for this is just:

-        if not disk.format:
+        if not disk.format or not disk.format.partitions:

?

Comment 16 Petr Schindler 2016-06-13 17:27:49 UTC
Discussed at 2016-06-13 blocker review meeting: [1]. 

This bug was accepted as Final blocker: this appears to completely prevent install from USB media, which is a clear violation of "The installer must be able to complete an installation using any supported locally connected storage interface" (Alpha criterion) in the case of a USB install medium, which we consider more than sufficient to constitute a violation

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-06-13/f24-blocker-review.2016-06-13-16.04.html

Comment 17 Adam Williamson 2016-06-13 17:30:42 UTC
Well, or:

-    for disk in storage.disks:
+    for disk in storage.partitioned:

since the 'partitioned' property is defined as 'A list of the partitioned devices in the device tree.' (in contrast to disks, which is 'A list of the disks in the device tree.')

but then, still, wouldn't it be checking disks that aren't selected as install targets, and thus might give an error if a partition on a disk not selected as an install target was mounted (e.g. to copy some file out of the installer environment or whatever reason you might have for doing that)?

I think the safest thing to do for F24 might just be to revert the commit, given that the bug wasn't a blocker or even an FE. For Rawhide we could try to fix the check...

Comment 18 Adam Williamson 2016-06-13 17:34:52 UTC
oh, sorry, #1330820 was given a freeze exception. But it's not a blocker, so we certainly can revert this if we want to.

Comment 19 joerg.lechner 2016-06-13 18:42:29 UTC
This Bug was originated 2016-06-11 16:10 EDT by jhawk 
Bug 1344856 - AttributeError: 'Iso9660FS' object has no attribute 'partitions'
was originated 2016-06-11 14:38 EDT by joerg.lechner@aol.de 

For correctness only: Why is 1344856 marked as duplicate and not and not Bug 1344863 - AttributeError: 'Iso9660FS' object has no attribute 'partitions' ?

For me it's not important, because I don't collect bugs, I only report problems.

But in my opinion is for correctness and fairness david shea should close this bug and reopen the other again.

Comment 20 Fedora Update System 2016-06-14 00:12:09 UTC
anaconda-24.13.7-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a8ecdc2c01

Comment 21 Fedora Update System 2016-06-14 03:57:14 UTC
anaconda-24.13.7-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a8ecdc2c01

Comment 22 joerg.lechner 2016-06-14 12:27:14 UTC
made the following on F24 Final 1.1 Desktop live user:
Run "Live User CD", update anaconda, see protocol:

[liveuser@localhost ~]$ su
[root@localhost liveuser]# dnf config-manager --set-enabled updates-testing
[root@localhost liveuser]# dnf update anaconda
Fedora 24 - x86_64                              6.1 MB/s |  47 MB     00:07    
Fedora 24 - x86_64 - Test Updates               4.1 MB/s | 5.6 MB     00:01    
Fedora 24 - x86_64 - Updates                    5.1 kB/s | 257  B     00:00    
Dependencies resolved.
================================================================================
 Package              Arch       Version              Repository           Size
================================================================================
Upgrading:
 anaconda             x86_64     24.13.7-1.fc24       updates-testing      69 k
 anaconda-core        x86_64     24.13.7-1.fc24       updates-testing     1.4 M
 anaconda-gui         x86_64     24.13.7-1.fc24       updates-testing     402 k
 anaconda-tui         x86_64     24.13.7-1.fc24       updates-testing     164 k
 anaconda-widgets     x86_64     24.13.7-1.fc24       updates-testing      98 k

Transaction Summary
================================================================================
Upgrade  5 Packages

Total download size: 2.1 M
********************************
*********************************

Afterwards the installation on my ACER E15 E5-571G laptop was ok, no problems.
For me works, but this only valid for my hardware bug 1344856, for bug 1344863
I don't know - other hardware.

Comment 23 Adam Williamson 2016-06-14 21:33:26 UTC
confirmed fixed in RC 2.

Comment 24 Fedora Update System 2016-06-16 00:02:29 UTC
anaconda-24.13.7-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 oatmeal.enthusiast 2016-08-21 18:30:38 UTC
*** Bug 1368835 has been marked as a duplicate of this bug. ***

Comment 26 krdondon 2016-09-13 09:27:41 UTC
*** Bug 1375505 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.