Bug 1344904 - It is invalid to cockpit HE UI when displaying "During customization use CTRL-D to abort."
Summary: It is invalid to cockpit HE UI when displaying "During customization use CTRL...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: UI
Version: 4.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ovirt-4.0.1
: 4.0
Assignee: Ryan Barry
QA Contact: Ying Cui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-12 11:47 UTC by Ying Cui
Modified: 2016-08-04 13:32 UTC (History)
7 users (show)

Fixed In Version: cockpit-ovirt-dashboard-0.10.6-1.2.0.el7ev.noarch.rpm
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-04 13:32:22 UTC
oVirt Team: Node
rule-engine: ovirt-4.0.z+
rule-engine: planning_ack+
fdeutsch: devel_ack+
ycui: testing_ack+


Attachments (Terms of Use)
invalid_sentence_cockpit (56.00 KB, image/png)
2016-06-12 11:49 UTC, Ying Cui
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 60373 0 master MERGED dashboard: Don't show "Press CTRL-D..." during HE setup 2016-07-07 19:12:21 UTC
oVirt gerrit 60413 0 ovirt-4.0 MERGED dashboard: Don't show "Press CTRL-D..." during HE setup 2016-07-08 14:48:40 UTC

Description Ying Cui 2016-06-12 11:47:29 UTC
Description:
UI displays "During customization use CTRL-D to abort.", CTRL-D is for HE deploy cmdline termination, does not apply to UI, and UI already existed button "Cancel Setup" to abort the setup, so here should avoid such invalid sentence display in UI.


Version-Release number of selected component (if applicable):
rhev-hypervisor7-ng-4.0-20160608.0.x86_64
imgbased-0.7.0-0.1.el7ev.noarch
ovirt-hosted-engine-ha-2.0.0-1.el7ev.noarch
ovirt-hosted-engine-setup-2.0.0.1-1.el7ev.noarch
redhat-release-rhev-hypervisor-4.0-0.6.el7.x86_64
vdsm-4.18.2-0.el7ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Installed rhev-hypervisor7-ng-4.0-20160608.0 successful.
2. root user login Cockpit UI
3. Navigate to Hosted-Engine UI
4. Click on "Start" to deploy Hosted Engine

Actual Result:
"During customization use CTRL-D to abort." displays in UI, but CTRL-D does not apply to UI.

Expected Result:
The sentence is invalid to cockpit, and will probably confuse user, so here should not show it in UI,

Comment 1 Ying Cui 2016-06-12 11:49:16 UTC
Created attachment 1167116 [details]
invalid_sentence_cockpit

Comment 2 Fabian Deutsch 2016-06-12 20:20:42 UTC
Would be interesting if we could also support to use ctrl-d for abortion in Cockpit.

Maybe this should even be solved in he-setup.

Comment 3 Red Hat Bugzilla Rules Engine 2016-06-13 06:35:28 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 4 Ryan Barry 2016-07-07 17:46:52 UTC
(In reply to Fabian Deutsch from comment #2)
> Would be interesting if we could also support to use ctrl-d for abortion in
> Cockpit.

There are problems with default keybindings in browsers here. Ctrl+D sets a bookmark in many...

Comment 5 Ying Cui 2016-08-01 09:26:13 UTC
VERIFIED this bug on cockpit-ovirt-dashboard-0.10.6-1.3.1.el7ev.

Ctrl + D will not be shown it in cockpit UI after starting the Hosted Engine deployment.


Note You need to log in before you can comment on or make changes to this bug.