Bug 134492 - tracking to include indic fonts into fonts.conf
tracking to include indic fonts into fonts.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
: i18n
Depends On:
Blocks: Indic
  Show dependency treegraph
 
Reported: 2004-10-03 22:16 EDT by Leon Ho
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 20:10:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
indic fonts, rendered with autohinting (18.21 KB, image/png)
2004-10-19 19:19 EDT, Owen Taylor
no flags Details
Indic fonts, rendered without hinting (19.82 KB, image/png)
2004-10-19 19:27 EDT, Owen Taylor
no flags Details
gedit, Bengali, 10pt, hinting (25.32 KB, image/png)
2004-10-20 12:50 EDT, Owen Taylor
no flags Details
Bengali, 10 pt, No hinting (25.95 KB, image/png)
2004-10-20 12:51 EDT, Owen Taylor
no flags Details

  None (edit)
Description Leon Ho 2004-10-03 22:16:28 EDT
Description of problem:
It is sane to add indic font names once it is available into fonts.conf.

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. vi /etc/fonts/fonts.conf
2.
3.
  
Actual results:
does not have indic fonts

Expected results:
should have indic fonts

Additional info:
Comment 1 Owen Taylor 2004-10-19 19:19:23 EDT
Created attachment 105474 [details]
indic fonts, rendered with autohinting
Comment 2 Owen Taylor 2004-10-19 19:27:51 EDT
Created attachment 105475 [details]
Indic fonts, rendered without hinting

One question not covered here is whether to leave autohinting enabled for
the Lohit font or not. I've attached images of them both ways (also included
Mukthi in the images ... we've disabled hinting for that since FC2).

The sizes in the image are 10,11,12,14,16,18.

The hinted versions are clearly better for all sizes for the Tamil, Gujarati,
and Punjabi fonts. For Bengali, Hindi there are some problems with the 
connections of the baseline, but I think the improvement in clarity is
important
enough to ignore that. So I'm going to leave autohinting on in our fonts.conf

If we fixed the libgnomeprint problems with OTF/CFF fonts, converting the
fonts to OTF/CFF might give us the best of both worlds -- clear rendering
plus no baseline problems. But the libgnomeprint fix is non-trivial.

We see as well, that we *really* need to figure out some way of getting
larger default font sizes for Indic fonts (as well as for CJK) the 

The fonts.conf in fontconfig-2.2.3-5 (building now) should have the right 
configuration; I also fixed up the fontconfig orthographies for ta, pa, so 
fontconfig correctly identifies the Lohit fonts as covering these languages.
Comment 3 Leon Ho 2004-10-19 23:43:46 EDT
From the comparsion, agreed let's leave autohinting for now. We will
rethink that if community have other good vaild reasons.

However one thing to note is that the font vendor has asked us to
disable hinting (he said he tested on FC1 and it is not good. Maybe it
because older version of freetype)?

Yup. The font size is the top priority for vendor to fix. I am going
to keep follow up with them on this problem.

For libgnomeprint, i will probably submit a bug in upstream and our bz
so we can keep track of it.
Comment 4 Owen Taylor 2004-10-20 00:22:33 EDT
While the Bengali fonts and Hindi fonts definitely should be
larger within the char cell, I think the font size problem is
also in the GNOME size ... there is just no expectation that
Bengali, or Chinese, or Thai, or, ... will be usable with a 10
point font. We need to be able to vary the font size depending
on locale.

My plan for this is to basically keep a separate font 
configuration variable for each language that the user logs in 
with ... so if they set the font in en_US, it won't affect what
they get when they log in zh_CN and vice versa. This allows
us to have a default that varies with locale.

We might even be able to do that for RHEL4.
Comment 5 Jatin Nansi 2004-10-20 05:21:27 EDT
I would really recommend turning off hinting for hindi and bengali. I
have spoken to native speakers of the languages, and readibility is
better with hinting turned off for these 2 languages. 
punjabi, gujarati and tamil seem to be better with hinting.
Comment 6 Owen Taylor 2004-10-20 12:50:43 EDT
Created attachment 105528 [details]
gedit, Bengali, 10pt, hinting
Comment 7 Owen Taylor 2004-10-20 12:51:28 EDT
Created attachment 105529 [details]
Bengali, 10 pt, No hinting
Comment 8 Owen Taylor 2004-10-20 12:55:40 EDT
As much as I'd like to defer to native speakers on this, the
combination of tiny font size and no hinting is, IMO, unacceptably
bad and I'd be embarassed to ship that way. (Not that I'm not
embarassed about how it looks with hinting on as well :-()

Bengali really isn't readable at 10 pt either way. But without
hinting, it's pretty close to nothing more than a blur. If we can 
resolve the font size issue for RHEL4, I'd be willing to reconsider the 
hinting question.
Comment 9 Leon Ho 2004-10-20 13:02:38 EDT
Good point. I think this decision is good until we got resolution on
font sizes.

Note You need to log in before you can comment on or make changes to this bug.