Bug 134514 - Disk Geometry detection fails -> install failure
Disk Geometry detection fails -> install failure
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-04 05:06 EDT by Panu-Kristian Poiksalo
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-22 23:39:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panu-Kristian Poiksalo 2004-10-04 05:06:25 EDT
Description of problem:

When running installer, assertion failure:
"Assertion (heads<256) at disk_dos.c:472 in function 
probe_partition_for_geom() failed"
This happens after selecting keyboard layout.

After that /dev/hda partitioning fails(?) and installer shuts down. 

Red Hat 9, in the same situation, reports in plaintext that partition 
table is incoherent, possibly resulting from misdetection of CHS of 
disk; safe to ignore but may cause boot loader problems.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Expected results:

Additional info:
Disk: ST38420A 3.05, 8 gigabytes at motherboard primary ide master.
Motherboard: msi k7tpro2 ver 1
Processor: AMD duron 750 mhz

Only disk in this IDE. Secondary IDE is connected to CDROM.
Comment 1 Jeremy Katz 2004-10-04 08:46:04 EDT
This will be fixed with the newer parted in test3.
Comment 3 Alex Bruno 2004-11-05 11:31:52 EST
Hit this on a dual-boot install. Partition table to follow.
Comment 4 Alex Bruno 2004-11-05 11:37:18 EST
Error messages generated by parted are:

Assertion (heads <256) at disk_dos.c:486 in function
probe_partition_for_geom() failed.

Assertion ((C * heads + H) * sectors + S ==A) at disk_dos.c: 495 in
function probe_partition_for_geom() failed.

fdisk reads the partition table just fine.
Comment 5 Jeremy Katz 2004-11-05 11:39:07 EST
Alex -- dual boot install of _what_?
Comment 6 Alex Bruno 2004-11-05 11:45:15 EST
Windows XP Home
Comment 7 Elliot Lee 2004-11-05 11:48:51 EST
Sorry, this is installing FC3 final onto a system that already has
WinXP installed. Alex should be providing the 'fdisk -l' output shortly.
Comment 8 Alex Bruno 2004-11-05 12:22:55 EST
Disk /dev/hda: 60.0GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device   Boot    Start     End    Blocks    ID   System
/dev/hda1  *        1     2550     20482843  7    HPFS/NTFS
Comment 9 Jeremy Katz 2004-11-22 23:39:53 EST

*** This bug has been marked as a duplicate of 138419 ***

Note You need to log in before you can comment on or make changes to this bug.