Bug 134526 - server install not give graphical or text boot choice
server install not give graphical or text boot choice
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-04 09:32 EDT by Jerry Geis
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 09:42:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry Geis 2004-10-04 09:32:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

Description of problem:
I presently had redhat 9 with at somepoint gave the option
of booting in graphical or text mode. (server install).

I now grabbed FC3t2 and did an install and this option was not present.

I wish to graphically install which it did, select server 
as my install option, select the X window packages as I may 
wish to startx manually for some other reason but I want my
machine to boot in text mode because I dont what the memory
taken up by X when running.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.graphical install of FC3t2
2. Did not see menu option to boot in grpahical mode or text mode
3.
    

Actual Results:  Always boots in graphical mode.

I know I can edit the /etc/inittab file
but the install time selection was really nice.

Additional info:
Comment 1 Jeremy Katz 2004-10-04 09:42:28 EDT
This is intentional.
Comment 2 Jerry Geis 2004-10-04 09:48:54 EDT
Intential why? I could see if a use selects a desktop install then
certainly not show the selection. However, for a server install like I
inticated I think it is perfectly reasonable to install X compenents 
but not wanting to boot into X by default.

Is something wrong with my logic there?
Comment 3 Jeremy Katz 2004-10-04 09:50:45 EDT
For one thing, all X configuration is now done post-install, so
there's not a logical place to put such a switch.  The thinking is
also that if you're installing a server, you'll have to configure the
service afterwards anyway and so if you really don't want to boot into
runlevel 5, you'll do it then while you're turning on and configuring
the service.

Note You need to log in before you can comment on or make changes to this bug.