Bug 134530 - Oops mounting lock_dlm filesystem
Oops mounting lock_dlm filesystem
Status: CLOSED DUPLICATE of bug 134354
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Teigland
GFS Bugs
Depends On:
  Show dependency treegraph
Reported: 2004-10-04 10:13 EDT by Derek Anderson
Modified: 2010-01-11 21:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:06:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Derek Anderson 2004-10-04 10:13:57 EDT
Description of problem:
Had a quorate 3-node cluster, made a filesystem with -p lock_dlm on a
device (no lvm involved) and mounted on the first node.  It Oopsed. 
Will reproduce and try to get more information:

Unable to handle kernel NULL pointer dereference at virtual address
 printing eip:
*pde = 00000000
Oops: 0000 [#1]
Modules linked in: gfs loop lock_dlm dlm cman lock_harness ipv6
parport_pc lp parport autofs4 sunrpc e1000 floppy sg microcode dm_mod
uhci_hcd ehci_hcd button battery asus_acpi ac ext3 jbd qla2300 qla2xxx
scsi_transport_fc sd_mod scsi_mod
CPU:    0
EIP:    0060:[<e041419d>]    Not tainted
EFLAGS: 00010292   (
EIP is at queue_complete+0xd/0x100 [lock_dlm]
eax: 00000000   ebx: 00000000   ecx: e0415050   edx: 00000001
esi: daf3d3d8   edi: df48ae00   ebp: 00000005   esp: dad35f1c
ds: 007b   es: 007b   ss: 0068
Process dlm_astd (pid: 5314, threadinfo=dad34000 task=db14a850)
Stack: 00000000 e02e008f 00000018 00000246 398bcf80 000f4456 db14aa04
       daa3350c daa3350c daf3d3d8 e02cd448 00000246 398bcf80 000f4456
       c13f7ca0 df48ae98 00000000 e0415060 e0415050 dad35fa4 e02ead8c
Call Trace:
 [<e02e008f>] _release_rsb+0x13f/0x2b0 [dlm]
 [<e02cd448>] process_asts+0x108/0x1e0 [dlm]
 [<e0415060>] lock_bast+0x0/0x5 [lock_dlm]
 [<e0415050>] lock_ast+0x0/0x10 [lock_dlm]
 [<e02cdca0>] dlm_astd+0x0/0x220 [dlm]
 [<e02cde95>] dlm_astd+0x1f5/0x220 [dlm]
 [<c011efb0>] default_wake_function+0x0/0x10
 [<c011efb0>] default_wake_function+0x0/0x10
 [<c0134fa4>] kthread+0xa4/0xb0
 [<c0134f00>] kthread+0x0/0xb0
 [<c01042b5>] kernel_thread_helper+0x5/0x10
Code: 8b 30 8b 40 34 a9 80 00 00 00 75 47 c7 04 24 34 8d 41 e0 8b

Filesystem make command:
[root@link-10 root]# gfs_mkfs -t MILTON:data1 -j 2 -p lock_dlm /dev/sdg15

Version-Release number of selected component (if applicable):
[root@link-11 root]# gfs_mkfs -V
gfs_mkfs DEVEL.1096560308 (built Sep 30 2004 11:06:29)
Copyright (C) Red Hat, Inc.  2004  All rights reserved.

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Derek Anderson 2004-10-04 11:08:43 EDT

*** This bug has been marked as a duplicate of 134354 ***
Comment 2 Kiersten (Kerri) Anderson 2004-11-16 14:08:18 EST
Updating version to the right level in the defects.  Sorry for the storm.
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.