Bug 134531 - pvmove fails with device-mapper error
Summary: pvmove fails with device-mapper error
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-04 14:34 UTC by Marc Wallman
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 20:36:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marc Wallman 2004-10-04 14:34:48 UTC
Description of problem:

pvmove fails with device-mapper error.

The system with the problem was installed from scratch with 
a root LVM filesystem. After installation, an old LVM1 volume
group (localvg1) was converted to LVM2 and imported into new 
volume group (localvg2). All volumes function properly other
than the pvmove failing. The old volume group was created
under RHEL v3WS.

Version-Release number of selected component (if applicable):

lvm2-2.00.21-2
kernel-2.6.8-1.528.2.10

How reproducible:

Every time

Steps to Reproduce:
1. Run pvmove
2.
3.
  
Actual results:

[root@rutabaga ~]# pvmove -v -n /dev/localvg2/home /dev/sda1 /dev/hda2
    Finding volume group "localvg2"
    Archiving volume group "localvg2" metadata.
    Creating logical volume pvmove0
  mirror: Required device-mapper target(s) not detected in your kernel
[root@rutabaga ~]#    


Expected results:

The move should succeed.

Additional info:

Comment 1 Alasdair Kergon 2004-10-04 20:36:36 UTC
You'll need to load the dm-mirror module into your kernel.

Newest 'mkinitrd' see this done automatically at boot time.

(See also bz #122991.)



Note You need to log in before you can comment on or make changes to this bug.